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Erreur "SSL_connect: certificate verify failed" lors de la connexion à Cloudera Hadoop

Date de publication: Jul 20, 2023
Description
Lors de la connexion à un serveur Cloudera Hadoop Hive ou Impala depuis Tableau Desktop, l'une des erreurs suivantes peut se produire :
[Cloudera][ImpalaODBC] (100) Error from the Impala Thrift API:SSL_connect: certificate verify failed (Erreur de l'API Impala Thrift : SSL_connect : la vérification du certificat a échoué)
ou
[Cloudera][Hardy] (34) Error from server: SSL_connect: certificate verify failed. (Erreur du serveur : SSL_connect : la vérification du certificat a échoué)

Ou lors de la connexion depuis Tableau Server, cette erreur peut se produire :
Unable to connect to the data source. (Impossible de se connecter à la source de données.)
Try connecting again. If the problem persists, disconnect from the data source and contact the data source owner. (Impossible de se connecter à la source de données. Essayez de vous reconnecter. Si le problème persiste, déconnectez-vous de la source de données et contactez le propriétaire de la source de données)
Unable to connect to the ODBC Data Source. Check that the necessary drivers are installed and that the connection properties are valid. (Impossible de se connecter à la source de données ODBC. Vérifiez que les pilotes nécessaires sont installés et que les propriétés de connexion sont valides.)
[Cloudera][ImpalaODBC] (100) Error from the Impala Thrift API: SSL_CTX_load_verify_locations: error code: 0 (Erreur de l'API Impala Thrift0 : SSL_CTX_load_verify_locations : Code d'erreur : 0)
Unable to connect to the server <name>. Check that the server is running and that you have access privileges to the requested database. (Impossible de se connecter au serveur <server name>. Vérifiez que le serveur est en cours d'exécution et que vous disposez de privilèges d'accès à la base de données demandée.)

Cause

Tableau Desktop ou Tableau Server n'est pas en mesure d'accéder au certificat SSL. 
Résolution
Adressez-vous à votre service informatique local pour essayer l'une des options suivantes :

Option 1 :

Installez le certificat Impala SSL dans le certificat racine en utilisant le Gestionnaire de certificats Windows (certmgr.msc) ou via une stratégie de groupe.

Option 2 :

  1. Enregistrez une copie du certificat .pem depuis le serveur Impala sur l'ordinateur exécutant Tableau Desktop. 
  2. Téléchargez et modifiez le fichier TDC pour spécifier le chemin d'accès de fichier aux certificats de confiance (doubles guillemets non requis), puis ajoutez le fichier .tdc aux emplacements suivants :
    1. (Tableau Desktop) : Dossier My Tableau Repository\Datasources.
    2. (Tableau Server pour Windows) : Dans le répertoire de données Tableau Server sous tabsvc\vizqlserver\Datasources. Le chemin d'accès par défaut est C:\ProgramData\Tableau\Tableau Server\data\tabsvc\vizqlserver\Datasources
    3. (Tableau Server pour Linux) : Dans le répertoire de données Tableau Server sous tabsvc/vizqlserver/Datasources. Le chemin d'accès par défaut est /var/opt/tableau/tableau_server/data/tabsvc/vizqlserver/Datasources/

Option 3 :

Remplacez le fichier cacerts.pem installé avec les pilotes ODBC par le certificat auto-signé créé pour le serveur de base de données. Exemples d'emplacements possibles pour le fichier :
C:\Program Files (x86)\Cloudera ODBC Driver for Impala\lib
C:\Program Files\Cloudera ODBC Driver for Apache Hive\lib 
Ressources supplémentaires
Pour toutes les modifications apportées à Tableau Server, les modifications doivent être appliquées à tous les nœuds utilisant des processus qui établissent des connexions à des sources de données (Backgrounder, serveur de données, Vizportal, VizQL Server).
Si vous utilisez l'Option 2 sur Tableau Server, le fichier TDC doit correspondre exactement à sa contrepartie sur Tableau Desktop : même lettre de lecteur, même chemin d'accès du fichier et même nom de fichier .PEM.
 

Numéro d’article de la base de connaissances

001473448

Pièces jointes

hadoopssl2.tdc

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Salesforce Help | Article