Loading

Errore "SSL_connect: certificate verify failed" duranta la connessione a Cloudera Hadoop

Data pubblicazione: Jul 20, 2023
Descrizione
Quando ci si connette a un server Cloudera Hadoop Hive o Impala da Tableau Desktop, può verificarsi uno dei seguenti errori:
[Cloudera][ImpalaODBC] (100) Error from the Impala Thrift API:SSL_connect: certificate verify failed ([Cloudera][ImpalaODBC] (100) Errore dall'API:SSL_connect Thrift Impala: verifica certificato non riuscita)
o
[Cloudera][Hardy] (34) Error from server: SSL_connect: certificate verify failed. ([Cloudera][Hardy] (34) Errore dal server: SSL_connect: verifica certificato non riuscita).

Oppure quando ci si connette da Tableau Server, potrebbe verificarsi questo errore:
Unable to connect to the data source.
Try connecting again. If the problem persists, disconnect from the data source and contact the data source owner. (Impossibile connettersi all'origine dati. Riprova a connetterti. Se il problema persiste, disconnettiti dall'origine dati e contatta il proprietario).
Unable to connect to the ODBC Data Source. Check that the necessary drivers are installed and that the connection properties are valid. (Impossibile connettersi all'origine dati ODBC. Verifica che siano installati i driver necessari e che le impostazioni di connessione siano valide.)
[Cloudera][ImpalaODBC] (100) Error form the Impala Thrift API: SSL_CTX_load_verify_locations: error code: 0 ([Cloudera][ImpalaODBC] (100) Errore dall'API Thrift Impala: SSL_CTX_load_verify_location: codice di errore: 0)
Unable to connect to the server <name>. Check that the server is running and that you have access privileges to the requested database. (Impossibile connettersi al server <nome server>. Verifica che il server sia in funzione e che si disponga dei privilegi di accesso al database richiesto.)

Cause

Tableau Desktop o Tableau Server non è in grado di raggiungere il certificato SSL. 
Risoluzione
Collabora con l'assistenza IT locale per provare una delle opzioni seguenti:

Opzione 1:

Installa il certificato SSL Impala nel certificato radice utilizzando il gestore dei certificati di Windows (certmgr.msc) o tramite i criteri di gruppo.

Opzione 2:

  1. Salva una copia del certificato .pem dal server Impala al computer con Tableau Desktop in esecuzione. 
  2. Scarica e modifica il file TDC per specificare il percorso del file nei certificati attendibili (non sono necessarie virgolette doppie), quindi aggiungi il file .tdc a:
    1. (Tableau Desktop): La cartella My Tableau Repository\Datasources.
    2. (Tableau Server per Windows): Nella directory dati di Tableau Server sotto tabsvc\vizqlserver\Datasources. Il percorso predefinito è C:\ProgramData\Tableau\Tableau Server\data\tabsvc\vizqlserver\Datasources
    3. (Tableau Server per Linux): Nella directory dati di Tableau Server sotto tabsvc\vizqlserver\Datasources. Il percorso predefinito è /var/opt/tableau/tableau_server/data/tabsvc/vizqlserver/Datasources/

Opzione 3:

Sovrascrivi il file cacerts.pem installato con i driver ODBC con il certificato autofirmato creato per il server del database. Esempi di possibili posizioni del file: 
Driver ODBC C:\Program Files (x86)\Cloudera per Impala\lib
Driver ODBC C:\Program Files\Cloudera per Apache Hive\lib 
Risorse aggiuntive
Tutte le modifiche a Tableau Server devono essere applicate a tutti i nodi che utilizzano processi che effettuano connessioni a origini dati (Selezione background, Server di dati, Vizportal, VizQL Server).
Quando si utilizza l'opzione 2 su Tableau Server, il file TDC deve corrispondere esattamente alla sua controparte su Tableau Desktop: la stessa lettera di unità, lo stesso percorso del file e lo stesso nome del file PEM.
 

Numero articolo Knowledge

001473448

Allegati

hadoopssl2.tdc

0 KB

 
Caricamento
Salesforce Help | Article