Loading

Fehler "No Tableau Server user found" (Kein Tableau Server-Benutzer gefunden) nach Ändern des Besitzrechts und Aktualisieren der Arbeitsmappe, die einen veröffentlichten Extrakt enthält

Veröffentlichungsdatum: Jul 20, 2023
Beschreibung
Nach dem Ändern des Besitzrechts einer Arbeitsmappe oder veröffentlichten Datenquelle und anschließendem Aktualisieren der Arbeitsmappe, die den veröffentlichten Extrakt enthält, oder dem Verbinden mit der veröffentlichten Datenquelle kann der folgende Fehler auftreten: 
No Tableau Server user found. (Kein Tableau Server-Benutzer gefunden.)

Zusätzlich tritt möglicherweise der folgende Fehler auf:
com.tableausoftware.nativeapi.dll.DataSourceException: No Tableau Server user found. class DataSourceException Unable to connect to the server "<servername>". Check that the server is running and that you have access privileges to the requested database. (com.tableausoftware.nativeapi.dll.DataSourceException: Kein Tableau Server-Benutzer gefunden. class DataSourceException Konnte keine Verbindung mit dem Server "<servername>" herstellen. Prüfen Sie, ob der Server ausgeführt wird und ob Sie Zugriffsberechtigungen für die angeforderte Datenbank besitzen.)

Cause

Als Sicherheitsmaßnahme löschen Arbeitsmappen und Datenquellen die eingebetteten Anmeldeinformationen nach dem Ändern des Besitzrechts. Die Anmeldeinformationen müssen erneut eingegeben werden. 
Lösung

Schritt 1: Aktualisieren Sie die Anmeldeinformationen in der eingebetteten Arbeitsmappe und veröffentlichen sie erneut: 

  1. Laden Sie die Arbeitsmappe von Tableau Server herunter und öffnen Sie sie mit Tableau Desktop.
  2. Klicken Sie mit der rechten Maustaste auf die Datenquelle und deaktivieren Sie Extrakt verwenden (geben Sie alle etwaigen angeforderten Anmeldeinformationen ein).
  3. Klicken Sie mit der rechten Maustaste auf die Datenquelle und wählen Sie Extrakt verwenden aus.
  4. Navigieren Sie zu Server > Arbeitsmappe veröffentlichen.
  5. Klicken Sie auf Planung und Authentifizierung.
  6. Ändern Sie den Authentifizierungstyp von "Kein" zu "Eingebettet" und klicken Sie auf OK.
  7. Klicken Sie auf Veröffentlichen.
    • Klicken Sie auf Ja, wenn Sie gefragt werden, ob die bestehende Kopie überschrieben werden soll.
  8. Aktualisieren Sie die Arbeitsmappe, um die Funktionalität sicherzustellen. 

Schritt 2: Datenquellen auf Tableau Server und/oder Tableau Cloud

  • Auf Tableau Server muss die Verbindung bearbeitet oder die Datenquelle erneut mit den neuen Anmeldeinformationen veröffentlicht werden. 
  • Für Tableau Cloud mit Datenquellen, die über den Synchronisierungsclient aktualisiert werden, siehe den Abschnitt "Einbetten oder Aktualisieren von Datenbankanmeldeinformationen" im folgenden Artikel in unserer Online-Hilfe: Anzeigen oder Ändern von Einstellungen des Synchronisierungsclients.

 

Zusätzliche Ressourcen
Weitere Informationen über die Änderung des Besitzrechts finden Sie im Abschnitt Besitzrecht verwalten in der Online-Hilfe.

Wenn dieser Fehler beim Aktualisieren eines Extrakts gemeldet wird und sich das Besitzrecht NICHT geändert hat, siehe auch Fehler "No Tableau Server user found" ( (Kein Tableau Server-Benutzer gefunden) beim Aktualisieren einer Arbeitsmappe, die den veröffentlichten Extrakt enthält

Nummer des Knowledge-Artikels

001473465

 
Laden
Salesforce Help | Article