Loading

Error "No Tableau Server user found" After Changing Ownership and Refreshing Workbook that Contains a Published Extract

Publiseringsdato: Apr 25, 2025
Beskrivelse
After changing workbook or published data source ownership and then refreshing workbook containing published extract or connecting to published data source, the following error might occur: 
No Tableau Server user found.

Additionally, the following Tabcmd error might occur:
com.tableausoftware.nativeapi.dll.DataSourceException: No Tableau Server user found. class DataSourceException Unable to connect to the server "<servername>". Check that the server is running and that you have access privileges to the requested database.

Cause

As a security measure, workbooks and data sources delete the embedded credentials after changing ownership. The credentials need to be re-entered. 
Løsning

Step 1 - Update the credentials in the embedded workbook and republish: 

  1. Download the workbook from Tableau Server and open it with Tableau Desktop
  2. Right click on the data source and de-select Use Extrac (fill out any requests for credential information).
  3. Right click on the data source and select Use Extract.
  4. Navigate to Server > Publish Workbook.
  5. Click on Scheduling & Authentication.
  6. Change the Authentication type from "None" to "Embedded" and click OK.
  7. Click Publish.
    • Click Yes when asked to overwrite the existing copy
  8. Refresh the workbook to confirm functionality. 

Step 2 - Data sources on Tableau Server and/or Tableau Cloud

  • On Tableau Server the connection should be edited or the data source re-published with new credentials. 
  • On Tableau Cloud with data sources which update via the Sync Client, please see the section "Embed or update database credentials" in the following article from our Online Help: View or Change Sync Client Settings

 

Flere ressurser
For more information about ownership change, see the section Manage Ownership in the Online Help.

Additionally, if this error is received when refreshing an extract and the ownership did NOT change,see: Error "No Tableau Server user found" Refreshing Workbook Containing Published Extract

Knowledge-artikkelnummer

001473465

 
Laster
Salesforce Help | Article