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Errori "Sign in Failed" o "Tableau Server could not authenticate you automatically." durante l'autenticazione a Tableau Server via Kerberos

Data pubblicazione: Aug 24, 2022
Descrizione
Quando si esegue l'autenticazione a Tableau Server tramite Kerberos, in Tableau Server potrebbe comparire uno dei seguenti messaggi di errore:
Sign in Failed (Accesso non riuscito) 
 
O:

Tableau Server could not authenticate you automatically.
Sign in using your Tableau Server credentials. (Tableau Server non è in riuscito ad eseguire l'autenticazione automatica. Accedere usando le proprie credenziali Tableau Server)
 

Cause

Apache non è in grado di leggere il file keytab.
Risoluzione

Opzione 1

Verifica che il tuo browser sia configurato per Kerberos SSO. Per ulteriori informazioni, vedi Supporto browser per Kerberos SSO.

Opzione 2

A seconda dei requisiti di sicurezza del tuo ambiente, potrebbe essere necessaria una crittografia specifica. Per includere tutta la crittografia possibile, aggiungere il parametro "/crypto All" al comando ktpass nello script generato da Tableau Server. Vedi i dettagli del comando KTPASS in questo articolo: Ktpass su Microsoft Technet.

Opzione 3

A seconda dei requisiti del proprio ambiente, potrebbe essere necessario creare una keytab per più SPN sostituendo il comando ktpass nello script generato da Tableau Server con il seguente:
ktpass /princ HTTP/tableauserver.domain.lan@DOMAIN.LAN /pass !adpass! /ptype KRB5_NT_PRINCIPAL /out kerberos1SPN.keytab
ktpass /princ HTTP/tableau.mycompany.com@DOMAIN.LAN /pass !adpass! /ptype KRB5_NT_PRINCIPAL /in kerberos1SPN.keytab /out kerberos2SPN.keytab

Una volta eseguito, fornisci a Tableau Server il file generato kerberos2SPN.keytab.

Per maggiori informazioni, vedi i dettagli del comando KTPASS nella pagina di Ktpass su Microsoft Technet.

Opzione 4

Quando Tableau Server è configurato con più schede di rete, il traffico di rete potrebbe non essere instradato attraverso la scheda di interfaccia di rete desiderata, causando una mancata corrispondenza. 

Per risolvere questo problema, è possibile disabilitare la seconda scheda di rete o utilizzare la seguente procedura per assegnare le metriche a ciascuna scheda di rete sul computer.

Nota: l'aggiornamento del DNS o l'utilizzo del routing locale nel file etc\hosts per riferirsi all'indirizzo IP preferito non risolverà questo problema.

Assegnare metriche per ogni interfaccia di rete

Una metrica è un modo per indicare il "costo" di utilizzo di un'interfaccia di rete. Più elevata è la metrica, più costoso è l'uso. Per impostazione predefinita in Windows, Automatic Metric è abilitato, ma è possibile assegnare manualmente metriche a ciascuna interfaccia di rete per indicare quale interfaccia di rete è preferibile. Più bassa è la metrica, più l'interfaccia è preferita.

Per configurare manualmente le metriche di un'interfaccia di rete:

  1. Nel Pannello di controllo, fai clic su Rete e Internet.

  2. Fai clic su Centro connessioni di rete e condivisione.

  3. Fai clic su Modifica impostazioni adattatore.

  4. Fai clic con il tasto destro del mouse su un'interfaccia di rete e quindi su Proprietà.

  5. Seleziona Protocollo Internet versione 4 (TCP/IPv4) e fai clic su Proprietà.

  6. Nella scheda Generale, fai clic su Avanzate....

  7. Nella scheda Impostazioni IP, deseleziona Metrica automatica e immetti la metrica desiderata nella casella Metrica interfaccia.

    La metrica indica il costo di utilizzo dell'interfaccia, quindi dai alla tua interfaccia preferita un valore inferiore rispetto alle altre interfacce del computer.

Ripeti il processo per qualsiasi altra interfaccia, dando loro metriche in base alle loro preferenze. L'interfaccia utilizzata da Tableau Server dovrebbe essere l'interfaccia preferita e avere il valore più basso per la metrica. Ad esempio, dai all'interfaccia di rete preferita una metrica di 5 e all'interfaccia secondaria un valore di 10.

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Per ulteriori informazioni su Windows e sull'utilizzo della funzione metrica per le route IP, consulta la seguente documentazione Microsoft:

Risorse aggiuntive
Il seguente errore potrebbe apparire nel file error.log del gateway Apache (httpd) error.log:
 
gss_accept_sec_context() failed: Unspecified GSS failure.  Minor code may provide more information (, Wrong principal in request)
Numero articolo Knowledge

001473539

 
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