Loading

Après le remplacement de sources de données, les champs calculés disparaissent ou ne sont plus valides

Date de publication: Jul 14, 2023
Description
Lors du remplacement de la source de données d'origine, les champs calculés peuvent disparaître du volet Données et sont marqués comme non valides (affichés avec un « ! » rouge).

Cause

Si les champs calculés ont disparu : seuls les champs calculés qui sont utilisés sont transférés vers la nouvelle source de données pour éviter tout encombrement.

Si les champ calculés sont marqués comme non valides : un champ calculé peut cesser d'être valide pour deux raisons.
  1. Un champ issu des sources de données d'origine n'existe pas (y compris, mais sans s'y limiter, la modification du nom du champ) dans la nouvelle source de données.
  2. La nouvelle source de données ne prend pas en charge toutes les fonctions qui sont utilisées dans la source de données d'origine.
Résolution

Scénario 1 : Des champs calculés disparaissent

Essayez l'une des options suivantes :
  1. Après avoir remplacé la source de données, copiez et collez les champs calculés de la source de données d'origine dans la nouvelle source de données.
  2. Avant de remplacer la source de données, vérifiez que tous les champs calculés sont inclus dans au moins une feuille de calcul.

Scénario 2 : Les champs calculés sont marqués comme non valides

Essayez l'une des options suivantes :

  1. Remplacez les références d'un champ par le champ correct.Pour plus d'informations sur le remplacement des références d'un champ, consultez Remplacer les références d'un champ.
  2. Utilisez une source de données prenant en charge toutes les fonctions utilisées dans le calcul (l'extraction des données est une option).
Ressources supplémentaires


Discuter de cet article... Forum de commentaires
Numéro d’article de la base de connaissances

001473543

 
Chargement
Salesforce Help | Article