Loading

Fehler "No Tableau Server user found" bei der Verbindungsherstellung zur Datenquelle oder beim Anzeigen des Dashboards

Veröffentlichungsdatum: Aug 24, 2022
Beschreibung
Wenn Sie auf Tableau Server oder Tableau Cloud versuchen, auf Dashboards zuzugreifen oder Abonnement-E-Mails zu senden, wird möglicherweise der folgende Fehler angezeigt:

No server user found class DataSourceException Unable to connect to server <server name or IP address>. Check that the server is running and that access privileges to the requested database. (Klasse "DataSourceException" des Serverbenutzers wurde nicht gefunden. Herstellen einer Verbindung mit dem Server <Servername oder IP-Adresse> nicht möglich. Überprüfen Sie, ob der Server ausgeführt wird und berechtigt ist, auf die angeforderte Datenbank zuzugreifen.)

Wenn Sie über Tableau Desktop versuchen, eine Verbindung mit einer veröffentlichten Datenquelle herzustellen, wird möglicherweise der folgende Fehler angezeigt:
 
com.tableausoftware.controller.dataserver.SessionController - Error response. code:401 type:DataServerNoAuth msg:No Tableau Server user found. (com.tableausoftware.controller.dataserver.SessionController – Fehlerantwort. Code: 401 type:DataServerNoAuth -Meldung: Kein Tableau Server-Benutzer gefunden.)

Cause

Ursache 1: Der Benutzer ist nicht berechtigt, auf die veröffentlichte Datenquelle zuzugreifen.

Ursache 2: Ein Forward-Proxy stört die Kommunikation mit dem Datenserver. Die gesamte Kommunikation mit dem Datenserver erfolgt über HTTP.
Lösung
Für dieses Problem gibt es zwei allgemeine Ursachen.Befolgen Sie die nachstehenden Schritte entsprechend Ihrer Situation.

Ursache 1: Benutzerberechtigungen (Tableau Server und Tableau Cloud)

Wenn einige Benutzer und einige Arbeitsmappen betroffen sind, stellen Sie sicher, dass entweder:
Die betroffenen Benutzer über die CONNECT-Berechtigung auf die veröffentlichte Datenquelle verfügen.Siehe Für Datenquellen konfigurierbare Funktionen.
ODER
Die betroffenen Arbeitsmappen über vom Herausgeber eingebettete Anmeldeinformationen verfügen.

 

Ursache 2: Forward-Proxy (nur Tableau Server)

Wenn alle Benutzer und alle Arbeitsmappen oder Datenquellen betroffen sind und ein Forward-Proxyserver verwendet wird, konfigurieren Sie den Proxy, um sicherzustellen, dass die unter Konfigurieren eines Forward-Proxyservers aufgeführten Ausnahmen angegeben wurden.Beachten Sie, dass diese Konfiguration auf dem primären Computer und auf allen Arbeitscomputern in einer verteilten Umgebung erfolgen muss.
 
Zusätzliche Ressourcen
Wenn das Problem bei Arbeitsmappen mit eingebetteten Datenquellen auftritt, überprüfen Sie, ob Run-As-Benutzer für Tableau Server über die entsprechenden Berechtigungen verfügt. Weitere Informationen über das Festlegen aller entsprechenden Run-As-Benutzer-Berechtigungen finden Sie im folgenden Tableau-Hilfeartikel:Als Benutzer ausführen.
Nummer des Knowledge-Artikels

001473554

 
Laden
Salesforce Help | Article