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Error “No license found for 'TableauServer'” When Activating a Tableau Server License Key

Udgivelsesdato: Dec 23, 2025
Beskrivelse

When you try to activate a Tableau Server license key on some versions of Tableau Server, the following error might occur:

 

No license found for 'TableauServer'

 

In addition, no keys appear on the Manage Product Keys page.

Cause

The local tablicsrv service cannot connect to Tableau Server FlexNet Licensing service.

Løsning

Option 1

Set exceptions in the local firewall for the following processes:
  • tableau.exe
  • lmgrd.exe

Option 2

  1. Disable the local firewall on the computer.
  2. Disable the anti-virus. If you are unable to disable, then exclude the Tableau folder from the anti-virus.
  3. Open C:\Windows\System32\drivers\etc\hosts and delete or comment out any lines that contain: 127.0.0.1localhost, or the host name of the computer.
  4. Restart the FlexNet Licensing and Tableau Server License Manager (tablicsrv) services. For more information, see Restart a Service on Microsoft TechNet.
  5. Confirm that the Secondary Logon service is started and will continue to start automatically on startup:
    1. Follow the steps in Verify Tableau Service Settings.
    2. Right-click the service name, and then select Start.
    3. Right-click the service name, and then select Properties. Set Startup type to Automatic.
  6. Try connecting to Tableau Server again.
  7. Re-enable the local firewall.

     

      Yderligere ressourcer

      If the above solutions didn't resolve the issue, try the following troubleshooting options:

      • Check whether a firewall is blocking network traffic to the licensing server. Anti-Virus such as McAfee commonly enables its own firewall.
      • Check that Port 27000 is available.
      • Check that system date and time are correct.
      • Make sure to run Manage Product Keys as administrator.
      • If you are connected to a VPN, disable the VPN before activating the license key. The VPN can be enabled after you activate the license.
      • Both services should be set to run as System Account.
      • Although the error message appears during activation, a record in trusted storage is created. After services are restarted, a key appears on the Manage Product Keys page automatically.

      If none of the above solutions or troubleshooting steps resolve the issue, contact Tableau Technical Support and provide the following information:

      Related error messages that you might see in log files include:

       

      MessageLog fileMeaning
      lc_checkout return value: -95 (internal code)tabsrvlic.log or wgserver_lic.logtablicsrv cannot connect to FLEXnet.
      Vendor daemon can't talk to lmgrd (License server machine is down or not responding. (-96,491)tablicsrv.logtablicsrv cannot connect to FLEXnet.
      -97 (internal code)tabsrvlic.logtablicsrv cannot be started (check Log On As settings in Services)



      Vidensartikelnummer

      001473579

       
      Indlæser
      Salesforce Help | Article