Loading

Error “Extract failed to complete in 7200 seconds”

Publiceringsdatum: Sep 11, 2025
Beskrivning

An extract refresh fails with the following Tableau Server error:

Timeout Error - Canceling task that took longer than 7200 seconds
Extract failed to complete in 7200 seconds

Or

com.tableausoftware.nativeapi.dll.ResourceGovernorException: The query time resource limit (7200 seconds) was exceeded

Cause

The query exceeded the timeout variable set for extract refreshes.

Lösning

Option 1: Optimize the data source

Optimizing the data source so that the extract refresh completes before the backgrounder.querylimit is reached is recommended solution. Please refer to the Optimize Workbook Performance product help for information about optimization options.

 

Option 2: Increase the value for the backgrounder.querylimit parameter.

Before increasing the backgrounder query limit consider the impact it can have.

  • Increasing backgrounder query limit will allow backgrounder jobs to run longer which could increase backgrounder delays.
  • It will also allow larger data sources to be stored on the server increasing disk space and backup/restore times.
  • Tableau Cloud has a 2 hour query limit. If Tableau cloud is in your future we recommend option 1.


To update the backgrounder.querylimit on Tableau Server do the following:

  1. The value is set with the tsm configuration set command. Value is in seconds, and we suggest increasing the value in a max of 30 minute (1,800 second) increments. The following commands change the value to be 2.5 hours (9,000 second):
    tsm configuration set -k backgrounder.querylimit -v 9000
    tsm pending-changes apply
  2. Log in to Tableau Server and attempt to refresh the extract using the Refresh Now option.
    If the refresh fails with the same error after the 9000 seconds (or 2.5 hours), repeat these steps, setting the querylimit parameter value to 10800.
Knowledge-artikelnummer

001473597

 
Laddar
Salesforce Help | Article