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Tableau Server Time Zone Does Not Match Windows or Linux Server Time Zone

Udgivelsesdato: Jan 21, 2025
Beskrivelse
The Tableau Server time zone does not match the time zone of the computer running Tableau Server.
 

Cause

After installation, Tableau Server does not automatically detect changes to the time zone or locale of the computer on which it is installed.
Løsning
On Windows with TSM (TSM versions):
  1. On the computer running Tableau Server, open the Command Prompt as an administrator.
  2. At the command prompt, run the following commands in order: (for example, America/New_York)

    tsm stop
    tsm configuration set -k service.log.timezone -v "America/New_York"
    tsm pending-changes apply
    cd "{Tableau Server Install Folder}\packages\scripts.{Version}
    stop-administrative-services.cmd
    start-administrative-services.cmd
    (Wait until tsm status command returns "STOPPED" status)
    tsm start

On Linux:
  1. Login to the computer running Tableau Server as tsm user then run the following commands to stop Tableau Server
    $ tsm stop

    Run the following commands to check the current Time zone settings as root user:
    $ sudo su - root
    # date -R
    # ls -l /etc/localtime

    Check the Time zone list to find your preferred Time zone
    # timedatectl list-timezones

    To change and re-verify the Time Zone settings (for example , Asia/Tokyo):
    # timedatectl set-timezone Asia/Tokyo
    # date -R
    # ls -l /etc/localtime
    # exit (from root)

    Restart Tableau Server including Management processes to make it recognize the new timezone:
    $ tsm configuration set -k service.log.timezone -v "Asia/Tokyo"
    $ tsm pending-changes apply
    $ cd /opt/tableau/tableau_server/packages/scripts.{version}/
    $ sudo ./stop-administrative-services
    $ sudo ./start-administrative-services
    (Wait until tsm status command returns "STOPPED" status)
    $ tsm start
Vidensartikelnummer

001473649

 
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