Loading

Tableau Server-Zeitzone entspricht nicht der Windows- oder Linux-Server-Zeitzone

Veröffentlichungsdatum: Dec 28, 2023
Beschreibung
Die Tableau Server-Zeitzone entspricht nicht der Zeitzone des Computers, auf dem Tableau Server ausgeführt wird.
 

Cause

Nach der Installation erkennt Tableau Server Änderungen an der Zeitzone oder am Gebietsschema des Computers, auf dem die Software installiert ist, nicht automatisch.
Lösung
Unter Windows mit TSM (TSM-Versionen):
  1. Öffnen Sie auf dem Computer, auf dem Tableau Server ausgeführt wird, eine Eingabeaufforderung als Administrator.
  2. Führen Sie an der Eingabeaufforderung die folgenden Befehle der Reihe nach aus (z. B. Amerika/New_York):

    tsm stop
    tsm configuration set -k service.log.timezone -v "Amerika/New_York"
    tsm pending-changes apply
    cd "{Tableau Server-Installationsordner}\packages\scripts.{Version}
    stop-administrative-services.cmd
    start-administrative-services.cmd
    (Warten Sie, bis der Befehl tsm status den Status "STOPPED" zurückgibt)
    tsm start

Auf Linux:
  1. Melden Sie sich auf dem Computer, auf dem Tableau Server ausgeführt wird, als tsm-Benutzer an und führen Sie den folgenden Befehl aus, um Tableau Server zu beenden:
    $ tsm stop

    Führen Sie die folgenden Befehle aus, um die aktuellen Zeitzoneneinstellungen als Root-Benutzer zu überprüfen:
    $ sudo su - root
    # date -R
    # ls -l /etc/localtime

    Überprüfen Sie die Zeitzonenliste, um Ihre bevorzugte Zeitzone zu finden.
    # timedatectl list-timezones

    Zum Ändern und Überprüfen der Zeitzoneneinstellungen (z. B. Asien/Tokio):
    # timedatectl set-timezone Asien/Tokio
    # date -R
    # ls -l /etc/localtime
    # exit (from root)

    Starten Sie Tableau Server einschließlich der Verwaltungsprozesse neu, damit die neue Zeitzone erkannt wird:
    $ tsm configuration set -k service.log.timezone -v "Asien/Tokio"
    $ tsm pending-changes apply
    $ cd /opt/tableau/tableau_server/packages/scripts.{version}/
    $ sudo ./stop-administrative-services
    $ sudo ./start-administrative-services
    (Warten Sie, bis der Befehl tsm status den Status "STOPPED" zurückgibt)
    $ tsm start
Nummer des Knowledge-Artikels

001473649

 
Laden
Salesforce Help | Article