Loading

Le fuseau horaire de Tableau Server ne correspond pas au fuseau horaire de Tableau Server sur Windows ou de Tableau Server sur Linux

Date de publication: Dec 28, 2023
Description
Le fuseau horaire de Tableau Server ne correspond pas au fuseau horaire de l'ordinateur exécutant Tableau Server.
 

Cause

Après l'installation, Tableau Server ne détecte pas automatiquement les changements de fuseau horaire ou de paramètres régionaux sur l'ordinateur sur lequel il est installé.
Résolution
Sur Windows avec TSM (versions TSM) :
  1. Sur l'ordinateur exécutant Tableau Server, ouvrez l'invite de commande en tant qu'administrateur.
  2. À l'invite de commande, exécutez les commandes suivantes dans l'ordre : (par exemple, America/New_York)

    tsm stop
    tsm configuration set -k service.log.timezone -v "America/New_York"
    tsm pending-changes apply
    cd "{Tableau Server Install Folder}\packages\scripts.{Version}
    stop-administrative-services.cmd
    start-administrative-services.cmd
    (Attendez que la commande tsm status renvoie l’état « ARRÊTÉ »)
    tsm start

Sur Linux :
  1. Connectez-vous à l’ordinateur qui exécute Tableau Server en tant qu’utilisateur tsm puis exécutez les commandes suivantes pour arrêter Tableau Server
    $ tsm stop

    Exécutez les commandes suivantes pour vérifier les paramètres de fuseau horaire en tant qu’utilisateur root :
    $ sudo su - root
    # date -R
    # ls -l /etc/localtime

    Consultez la liste des fuseaux horaires pour rechercher votre fuseau horaire préféré
    # timedatectl list-timezones

    Pour modifier et vérifier à nouveau les paramètres de fuseau horaire (par exemple, Asia/Tokyo) :
    # timedatectl set-timezone Asia/Tokyo
    # date -R
    # ls -l /etc/localtime
    # exit (from root)

    Redémarrez Tableau Server ainsi que les processus de gestion pour qu’il reconnaisse le nouveau fuseau horaire :
    $ tsm configuration set -k service.log.timezone -v "Asia/Tokyo"
    $ tsm pending-changes apply
    $ cd /opt/tableau/tableau_server/packages/scripts.{version}/
    $ sudo ./stop-administrative-services
    $ sudo ./start-administrative-services
    (Attendez que la commande tsm status renvoie l’état « ARRÊTÉ »)
    $ tsm start
Numéro d’article de la base de connaissances

001473649

 
Chargement
Salesforce Help | Article