Loading

Tableau Server のタイム ゾーンが Windows または Linux サーバーのタイム ゾーンに一致しない

公開日: Dec 28, 2023
説明
Tableau Server のタイム ゾーンが Tableau Server を実行するコンピューターのタイム ゾーンと一致しない。
 

Cause

Tableau Server はインストール後、インストールされたコンピューターのタイム ゾーンやロケールの変更を自動的には検出しません。
解決策
Windows と TSM (TSM バージョン) の場合:
  1. Tableau Server を実行しているコンピューターで、管理者としてコマンド プロンプトを開きます。
  2. コマンド プロンプトで、次のコマンドを順番に実行します。(例: America/New_York)

    tsm stop
    tsm configuration set -k service.log.timezone -v "America/New_York"
    tsm pending-changes apply
    cd "{Tableau Server Install Folder}\packages\scripts.{Version}
    stop-administrative-services.cmd
    start-administrative-services.cmd
    (tsm status コマンドが "STOPPED" ステータスを返すまで待ちます)
    tsm start

Linux:
  1. Tableau Server を実行しているコンピューターに tsm ユーザーとしてログインし、次のコマンドを実行して Tableau Server を停止します。
    $ tsm stop

    root ユーザーとして次のコマンドを実行し、現在のタイム ゾーン設定を確認します。
    $ sudo su - root
    # date -R
    # ls -l /etc/localtime

    タイム ゾーンの一覧を確認し、優先するタイム ゾーンを探します。
    # timedatectl list-timezones

    次のようにしてタイム ゾーン設定を変更し (例: Asia/Tokyo)、再確認します。
    # timedatectl set-timezone Asia/Tokyo
    # date -R
    # ls -l /etc/localtime
    # exit (from root)

    管理プロセスを含めて Tableau Server を再起動し、新しいタイム ゾーンを認識させます。
    $ tsm configuration set -k service.log.timezone -v "Asia/Tokyo"
    $ tsm pending-changes apply
    $ cd /opt/tableau/tableau_server/packages/scripts.{version}/
    $ sudo ./stop-administrative-services
    $ sudo ./start-administrative-services
    (tsm status コマンドが "STOPPED" ステータスを返すまで待ちます)
    $ tsm start
ナレッジ記事番号

001473649

 
読み込み中
Salesforce Help | Article