Loading

Error "you must have the Connect permission...you are logged in as Guest"

Fecha de publicación: Aug 24, 2022
Descripción
En Tableau Server, cuando intenta abrir las vistas conectadas a fuentes de datos publicadas, puede aparecer uno de los siguientes errores:

Forbidden Action (Acción prohibida)
To access this workbook, you must have the Connect permission for its data sources. Because you are logged in as Guest, you do not have this permission. Log in as a named user to try again (Para acceder a este libro de trabajo debe tener permiso de conexión para sus fuentes de datos. No dispone de este permiso porque ha iniciado sesión como invitado. Inicie sesión con un usuario y vuelva a intentarlo).
 
o

HTTP 403
ERROR
Access Denied
Access Denied by security policy (ERROR 403. Acceso denegado. Acceso denegado por la directiva de seguridad).

Además, cuando intenta publicar un libro de trabajo conectado a una fuente de datos publicada, puede aparecer el error siguiente:
 
An error occurred while publishing. Internal server error. (Se ha producido un error durante la publicación. Error de servidor interno).

Cause

Este error se produce debido a la configuración del entorno externa a Tableau Server. 

Las comunicaciones internas de Tableau Server se redirigen a través de un proxy de reenvío (Internet), que solicita la autenticación. Las instalaciones distribuidas de Tableau Server requieren conexiones directas entre los equipos.
Solución
Consulte al equipo de TI para asegurarse de que las conexiones de salida de todos los equipos que ejecutan Tableau Server siempre omitan el proxy de reenvío (Internet) cuando se dirijan a las direcciones siguientes:
  • Direcciones IP de todos los equipos que ejecutan Tableau Server
  • Nombres de host de todos los equipos que ejecutan Tableau Server
  • localhost
Los pasos exactos necesarios para solucionar este problema varían en función del entorno. Si el proxy de reenvío está configurado manualmente en los equipos que ejecutan Tableau Server, se deben efectuar los siguientes pasos:
  1. Utilice la cuenta de Tableau Server Ejecutar como usuario para iniciar sesión en Windows en el equipo que ejecuta Tableau Server; a continuación, abra Internet Explorer. Para obtener más información, consulte Ejecutar como usuario en la Ayuda de Tableau.
  2. En Internet Explorer, seleccione Herramientas > Opciones de Internet.
  3. En la pestaña Conexiones, haga clic en Configuración de LAN.
    La casilla de verificación Usar un servidor proxy para la LAN debe estar marcada. Si esta casilla de verificación no está marcada, quiere decir que no está utilizando ningún proxy y el problema que aparece en este artículo no se aplica. 
  4. Haga clic en Opciones avanzadas
  5. En el campo Excepciones, añada localhost y las direcciones IP de todos los equipos del entorno distribuido de Tableau Server; a continuación, haga clic en Aceptar tres veces.
  6. Reinicie Tableau Server.
Recursos adicionales
El error puede variar en función del proxy.
Número del artículo de conocimiento

001473676

 
Cargando
Salesforce Help | Article