Loading

Erreur "you must have the Connect permission...you are logged in as Guest"

Date de publication: Aug 24, 2022
Description
Sur Tableau Server, lorsque vous tentez d'ouvrir des vues connectées aux sources de données publiées, l'une des erreurs suivantes peut se produire :

Action interdite
Pour accéder à ce classeur, vous devez disposer de l'autorisation de connexion pour ses sources de données. Du fait que vous êtes connecté en tant qu'invité, vous ne disposez pas de cette autorisation. Connectez-vous en tant qu'utilisateur nommé pour réessayer.
 
ou

HTTP 403
ERROR (ERREUR)
Access Denied (Accès refusé)
Access Denied by security policy (Accès refusé par la politique de sécurité)

En outre, lorsque vous tentez de publier un classeur connecté à une source de données publiée, l'erreur suivante peut se produire :
 
Une erreur s'est produite lors de la publication. Erreur serveur interne.

Cause

Cette erreur se produit en raison de configurations d'environnement extérieures à Tableau Server. 

Les communications internes Tableau Server sont redirigées via un proxy de transfert (Internet) qui nécessite une authentification. Les installations distribuées de Tableau Server nécessitent des connexions directes entre les ordinateurs.
Résolution
Collaborez avec votre équipe informatique pour vous assurer que les connexions sortantes de tous les ordinateurs exécutant Tableau Server ignorent toujours le proxy de transfert (Internet) lors de l'accès aux adresses suivantes :
  • Adresses IP de tous les ordinateurs exécutant Tableau Server
  • Noms d'hôte de tous les ordinateurs exécutant Tableau Server
  • localhost
La procédure exacte requise pour résoudre ce problème variera selon l'environnement. Si le proxy de transfert est configuré manuellement sur les ordinateurs exécutant Tableau Server, la procédure suivante peut s'appliquer :
  1. Utilisez le compte Exécuter en tant qu'utilisateur de Tableau Server pour vous connecter à Windows sur l'ordinateur exécutant Tableau Server, puis ouvrez Internet Explorer. Pour plus d'informations, voir Exécuter en tant qu'utilisateur dans l'aide de Tableau.
  2. Dans Internet Explorer, sélectionnez Outils > Options Internet.
  3. Dans l'onglet Connexions, cliquez sur Paramètres réseau.
    La case à cocher Utiliser un serveur proxy pour le réseau local doit être sélectionnée. Si cette case à cocher n'est pas sélectionnée, vous n'utilisez pas un proxy et le problème décrit dans cet article ne s'applique pas.
  4. Cliquez sur Avancé
  5. Dans le champ Exceptions, ajoutez localhost et les adresses IP de tous les ordinateurs de l'environnement distribué Tableau Server, puis cliquez sur OK trois fois.
  6. Redémarrez Tableau Server.
Ressources supplémentaires
L'erreur peut varier selon le proxy.
Numéro d’article de la base de connaissances

001473676

 
Chargement
Salesforce Help | Article