Loading

Errore "Database error: 0x80004005: Microsoft Office cannot open or write to the file"

Data pubblicazione: Aug 24, 2022
Descrizione
Quando si esegue un aggiornamento di una vista su Tableau Server o si seleziona una tabella di Access in Tableau Desktop, potrebbe essere visualizzato uno dei seguenti messaggi di errore:

com.tableausoftware.nativeapi.dll.DataSourceException: Database error 0x80004005: The Microsoft Office Access database engine cannot open or write to the file *. It is already opened exclusively by another user, or you need permission to view and write its data. (com.tableausoftware.nativeapi.dll.DataSourceException: Errore del database 0x80004005: il motore di database di Microsoft Office Access non può aprire o scrivere sul file *. È già aperto in esclusiva da un altro utente o è necessaria l'autorizzazione per visualizzare e scrivere i relativi dati.)
 

Unable to connect to the Microsoft Excel file "\\<file-path>.xlsx". Check that you have access privileges for the requested file and that it is not open in another application. (Impossibile connettersi al file Microsoft Excel "\\<percorso-file>.xlsx". Verifica di disporre dei privilegi di accesso per il file richiesto e che non sia aperto in un'altra applicazione.)

Access Database error: "Database error 0x80004005: The Microsoft Office Access database engine cannot open or write to the file [file location]. It is already opened exclusively by another user, or you need permission to view and write its data."​ (Errore del database di Access: "Errore del database 0x80004005: il motore di database di Microsoft Office Access non può aprire o scrivere nel file [percorso file]. È già aperto in esclusiva da un altro utente oppure è necessaria l'autorizzazione per visualizzare e scrivere i relativi dati.")

Cause

Questo problema è in genere causato da autorizzazioni insufficienti fornite all'account Utente Esegui come di Tableau Server o all'account utente del computer in cui è in esecuzione Tableau Desktop.
Risoluzione
  1. Assicurati che l'account Utente Esegui come di Tableau Server o l'account utente del computer in cui è in esecuzione Tableau Desktop disponga delle autorizzazioni per accedere al percorso in cui è stato salvato il file di Microsoft Access o Microsoft Excel. Se il file di Access contiene tabelle con collegamenti a un altro file, assicurati che gli account utente possano accedere anche al percorso delle origini dati collegate. Per maggiori informazioni, consulta Impostazioni dell'account Esegui come per confermare nella Guida di Tableau.
  2. Se il file di Access contiene tabelle con collegamenti a un altro file, verifica che il percorso dell'origine dati collegata sia corretto.
Numero articolo Knowledge

001473679

 
Caricamento
Salesforce Help | Article