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Fehler "Could not locate unexpired trusted ticket"

Veröffentlichungsdatum: Jun 30, 2023
Beschreibung
Beim Versuch, auf eine Site zuzugreifen, die die vertrauenswürdige Authentifizierung verwendet, tritt unter Umständen der folgende Fehler auf:

An error occurred on the server. The details of the error are:
Could not locate unexpired trusted ticket <ticket number>
Click the Refresh button in your web browser and try again.
If you continue to receive this error please contact your Tableau Server Administrator. (Ein Fehler ist auf dem Server aufgetreten. Die Fehlerdetails sind wie folgt: Das nicht abgelaufene vertrauenswürdige Ticket <Ticketnummer> wurde nicht gefunden. Klicken Sie in Ihrem Webbrowser auf "Aktualisieren", und versuchen Sie es erneut. Wenden Sie sich an Ihren Tableau Server-Administrator, falls dieser Fehler weiterhin auftritt.)

Cause

Wenn die notwendigen Daten nicht in der HTTP-Anfrage zu Tableau Server eingeschlossen sind, dann kann beim Lokalisieren eines nicht abgelaufenen Tickets möglicherweise ein Fehler auftreten. Standardmäßig wir eine "Standard-"Site verwendet, falls keine target_site angegeben wird.
Lösung
Stellen Sie sicher, dass die HTTP POST- und GET-Anfragen, die durch die Webanwendung oder den Client verwendet werden alle Werte, die von Tableau Server erfordert werden, um ein Trusted Ticket erfolgreich abzurufen, wie Username=<username>, target_site=<site id> und client_ip=<ip address> (optional) einschließen.

Option 1: Fehler bei der Ticketerstellung gefolgt von einem Versuch, ein fehlerhaftes Ticket abzurufen (wahrscheinlich -1)
Prüfen und stellen Sie sicher, dass eine gültige Ticketnummer erstellt und abgerufen wird.Wird ein Ticket mit "-1" generiert, finden Sie Angaben zu den nächsten Schritten unter https://onlinehelp.tableau.com/current/server/de-de/trusted_auth_trouble_1return.htm.

Option 2: Duplizierte Aufrufe für die gleiche Ticketnummer:
Wenn Sie feststellen möchten, ob Proxys mehrere Anforderungen für dasselbe Ticket senden, prüfen Sie den HTTPD-Order der Tableau Server-Protokolle. Weitere Informationen finden Sie unter Protokolldatei-Speicherorte.  

Für dieses Ticket sollte Ihnen nur eine Anforderung angezeigt werden, wobei auf "/trusted/" eine alphanumerische Zeichenfolge mit 9–255 Zeichen (standardmäßig 24) folgt. Wenn diese Information mehrmals angezeigt wird, fordert ein Proxy die URL mit dem Ticket mehrmals an, wie etwa in der ersten und dritten Zeile im folgenden Beispiel:
1.23.45.567 - - 2016-08-09 15:52:54.348 Pacific Daylight Time 80 "GET /trusted/bTf1vpt-xdncVZw4B5nmi1Np/views/viewname/dashboardname?:embed=y&:host_url=http://12.34.56.789/&:tabs=no&:toolbar=no&:loadOrderID=0 HTTP/1.1" "1.23.45.678" 321 - "-" 31200 UctMZgq1CGoAABrYHjwAAAAM
 
123.45.67.891 - - 2016-08-09 15:52:56.578 Pacific Daylight Time 80 "GET /trusted/4wphmumvWTkVw5Rl1UrSqxqv/views/viewname/dashboard name?:embed=y&:host_url=http://12.34.56.789/&:tabs=no&:toolbar=no&:loadOrderID=0 HTTP/1.1" "123.45.67.123" 432 1234 "-" 0 UctMmQq1CGoAABrYHkEAAAB0
 
123.45.678.91 - - 2016-08-09 15:52:58.213 Pacific Daylight Time 80 "GET /trusted/bTf1vpt-xdncVZw4B5nmi1Np/views/viewname/dashboardname?:embed=y&:host_url=http://12.34.56.789/&:tabs=no&:toolbar=no&:loadOrderID=0 HTTP/1.1" "123.45.67.123" 432 1234 "-" 15600 UctMxwq1CGoAABrYHkIAAAB0
 
Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben.

Hinweis:Wenn Sie die folgenden Änderungen vornehmen, lehnt Tableau Server GETs von nicht beabsichtigten Clients wie Proxys und anderen Sicherheitsscannern ab, sodass nur der festgelegte Clientbrowser das Ticket einlösen kann.
  1. Aktvieren Sie die Client-IP-Sicherheit, um sicherzustellen, dass der festgelegte Browser das vertrauenswürdige Ticket einlösen kann, bevor es vom Proxy eingelöst wird. Weitere Informationen finden Sie im Thema Optional: Konfigurieren des Client-IP-Abgleichs im Tableau Server-Administratorhandbuch.
  2. Stellen Sie sicher, dass die IP-Adresse des Clientbrowsers in der ursprünglichen POST-Anforderung an Tableau Server enthalten ist. Weitere Informationen zu POST-Anforderungen finden Sie im Abschnitt Abrufen eines Tickets von Tableau Server im Produkthilfeleitfaden.

Option 3 :Keine duplizierten Aufrufe für das Ticket, und die URL ist abgeschnitten:
Wenn die eingebettete Ansicht nicht korrekt initialisiert wird, durchläuft die URL den GET-Aufruf nicht. Nach dem vertrauenswürdigen Ticket sollte eine URL angezeigt werden, die den Namen der Ansicht enthält, die aber im unten angezeigten Protokolleintrag nicht enthalten ist:
 
123.45.678.91- - 2016-08-09 15:52:58.213 Pacific Daylight Time 443 "GET /trusted/w5DCZZDNtI8K42kzg7OyAM3p/ HTTP/1.1" "-" 403 1774 "-" 15649 V6pCqgoIAEQAADoYq48AAAIy 

Um das Problem zu beheben, stellen Sie sicher, dass die zum Einbetten der Ansicht verwendete URL das Symbol # nicht enthält. Weitere Informationen finden Sie unter Anzeigen der Ansicht mit dem Ticket. Aufgrund des Symbols # wird nicht die gesamte URL weitergegeben, wodurch ein Fehler beim Einlösen des Tickets auftritt.
  • Falsch erstellte URL für ein vertrauenswürdiges Ticket: http://myserver/trusted/<ticket>/#/views/<workbook>/<view>
  • Korrekt erstellte URL für ein vertrauenswürdiges Ticket: http://myserver/trusted/<Ticket>/t/<Site>/views/<Arbeitsmappe>/<Ansicht>
  • Korrekt erstellte URL für ein vertrauenswürdiges Ticket: http://myserver/trusted/<Ticket>/views/<Arbeitsmappe>/<Ansicht>
Hinweis: Wenn Tableau Server mehrere Sites ausführt und sich die Ansicht nicht auf der Standardsite befindet, müssen Sie an den Pfad t/<site ID> anfügen. Weitere Informationen finden Sie unter Was ist eine Site?.
Zusätzliche Ressourcen
Einige Gründe, warum ein Problem während eines Ticket Request aufgetreten ist und ein ungültiger Ticketwert empfangen wurde.
  • Das vertrauenswürdige Ticket wurde nicht innerhalb von drei Minuten verwendet.
  • Ein Proxy hat duplizierte Anforderungen an Tableau Server gesendet und hat aus Versehen das Ticket eingelöst, das in der URL enthalten war, und es so für spätere Anforderungen entwertet.
  • Die eingebettete URL ist falsch, schneidet die vollständige URL der Ansicht ab. Dieser Fehler ist auch aufgetreten, als der Code des vertrauenswürdigen Tickets den falschen Server zum Erstellen der GET-Anforderung verwendet hat.



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