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Error "Could not locate unexpired trusted ticket"

Fecha de publicación: Jun 30, 2023
Descripción
Cuando se trata de acceder a un sitio que utiliza autenticación confiable, podría producirse el siguiente error:

An error occurred on the server. The details of the error are:
Could not locate unexpired trusted ticket <ticket number>
Click the Refresh button in your web browser and try again.
If you continue to receive this error please contact your Tableau Server Administrator. (Se ha producido un error en el servidor. Los detalles del error son los siguientes: No se ha encontrado el vale de confianza sin caducar <número de vale>. Haga clic en el botón Actualizar del navegador e inténtelo de nuevo. Si sigue recibiendo este error, póngase en contacto con el administrador Tableau Server)

Cause

Se puede producir un error al encontrar un ticket que aún no ha expirado, cuando los datos necesarios no se han incluido en la solicitud HTTP en Tableau Server. Por defecto, se usará un sitio "predeterminado" si no se especifica un valor para target_site.
Solución
Compruebe que las solicitudes HTTP POST y GET usadas por la aplicación web o el cliente incluyen todos los valores necesarios de Tableau Server para solucionar un ticket de confianza, como los valores Username=<username>, target_site=<site id> y client_ip=<ip address> (opcional).

Opción 1: error al crear un vale seguido de un intento de canjear un vale incorrecto (probablemente -1)
Asegúrese de que se genere y canjee un número de vale que sea válido. Si se genera un vale de -1, consulte los pasos siguientes en https://onlinehelp.tableau.com/current/server/es-es/trusted_auth_trouble_1return.htm.

Opción 2: llamadas duplicadas para el mismo número de vale:
Para determinar si los proxies están enviando varias solicitudes correspondientes al mismo vale, compruebe la capeta HTTPD de los registros de Tableau Server. Para obtener más información, consulte Ubicaciones de los archivos de registro.  

Debería ver solamente una solicitud para este vale, donde "/trusted/" va seguido de una cadena de caracteres alfanuméricos de 9 a 255 (el valor predeterminado es 24). Si ve esta información más de una vez, significa que un proxy está solicitando la URL con el vale varias veces, en el caso del siguiente ejemplo, en la primera y la tercera línea:
1.23.45.567 - - 2016-08-09 15:52:54.348 Pacific Daylight Time 80 "GET /trusted/bTf1vpt-xdncVZw4B5nmi1Np/views/viewname/dashboardname?:embed=y&:host_url=http://12.34.56.789/&:tabs=no&:toolbar=no&:loadOrderID=0 HTTP/1.1" "1.23.45.678" 321 - "-" 31200 UctMZgq1CGoAABrYHjwAAAAM
 
123.45.67.891 - - 2016-08-09 15:52:56.578 Pacific Daylight Time 80 "GET /trusted/4wphmumvWTkVw5Rl1UrSqxqv/views/viewname/dashboard name?:embed=y&:host_url=http://12.34.56.789/&:tabs=no&:toolbar=no&:loadOrderID=0 HTTP/1.1" "123.45.67.123" 432 1234 "-" 0 UctMmQq1CGoAABrYHkEAAAB0
 
123.45.678.91 - - 2016-08-09 15:52:58.213 Pacific Daylight Time 80 "GET /trusted/bTf1vpt-xdncVZw4B5nmi1Np/views/viewname/dashboardname?:embed=y&:host_url=http://12.34.56.789/&:tabs=no&:toolbar=no&:loadOrderID=0 HTTP/1.1" "123.45.67.123" 432 1234 "-" 15600 UctMxwq1CGoAABrYHkIAAAB0
 
Para resolver este problema, siga los pasos que se indican a continuación.

Nota: al efectuar los siguientes cambios, Tableau Server rechazará las solicitudes GET procedentes de clientes no intencionados, como proxies y otros escáneres de seguridad, de tal modo que solo el navegador del cliente especificado puede canjear el vale.
  1. Active la seguridad de IP de cliente para cerciorarse de que el navegador especificado tenga la oportunidad de canjear el vale de confianza antes de que el proxy canjee el vale. Para obtener más información, consulte el tema Opcional: configurar una coincidencia de IP de cliente en la guía del administrador de Tableau Server.
  2. Asegúrese de que la dirección IP del navegador del equipo cliente esté incluida en la solicitud POST original a Tableau Server.Para obtener más información acerca de la solicitudes POST, consulte la sección Obtener un vale de Tableau Server de la guía de ayuda del producto.

Opción 3: no hay llamadas duplicadas para el vale y la URL está cortada:
Si la vista incrustada se inicializa correctamente, la URL no pasará la llamada GET. Después del vale de confianza, debería haber una URL que indicase el nombre de la vista, pero no aparece en la entrada de registro que figura a continuación:
 
123.45.678.91- - 2016-08-09 15:52:58.213 Pacific Daylight Time 443 "GET /trusted/w5DCZZDNtI8K42kzg7OyAM3p/ HTTP/1.1" "-" 403 1774 "-" 15649 V6pCqgoIAEQAADoYq48AAAIy 

Para solucionar este problema, compruebe que la URL utilizada para incrustar la vista no incluya el signo #.Para obtener más información, consulte Mostrar la vista con el vale. El signo # no pasará la URL completa, provocando así un error al canjear el vale.
  • Construcción incorrecta de la URL del vale de confianza: http://myserver/trusted/<vale>/#/views/<libro de trabajo>/<vista>
  • Construcción correcta de la URL del vale de confianza:http://myserver/trusted/<vale>/t/<sitio>/views/<libro de trabajo>/<vista>
  • Construcción correcta de la URL del vale de confianza: http://myserver/trusted/<vale>/views/<libro de trabajo>/<vista>
Nota: si Tableau Server está ejecutando varios sitios y la vista está en un sitio diferente del predeterminado, tendrá que añadir t/<site ID> a la ruta. Para obtener más información, consulte ¿Qué es un sitio?
Recursos adicionales
Estas son algunas razones por las que se puede producir un error durante la solicitud de un ticket y por las que se puede recibir un valor de ticket incorrecto.
  • El vale de confianza no se ha utilizado en un espacio de tiempo de tres minutos.
  • Un proxy ha enviado solicitudes duplicadas a Tableau Server y ha canjeado accidentalmente el vale que se encontraba en la URL, invalidándolo para posteriores solicitudes.
  • La URL insertada no es correcta, se solapa con la URL completa de la vista. Este error también se ha detectado cuando el código de ticket de confianza ha utilizado el servidor incorrecto para crear la solicitud GET.



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