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Errore "Could not locate unexpired trusted ticket"

Data pubblicazione: Jun 30, 2023
Descrizione
Quando accedi a un sito che utilizza un'autenticazione attendibile, potrebbe verificarsi il seguente errore:

An error occurred on the server. The details of the error are (Si è verificato un errore sul server i dettagli di questo errore sono):
Could not locate unexpired trusted ticket <ticket number> (Impossibile individuare il ticket attendibile non scaduto <numero del ticket>)
Click the Refresh button in your web browser and try again (Fare clic sul pulsante Aggiorna del proprio browser Web e riprovare).
If you continue to receive this error please contact your Tableau Server Administrator. (Se si continua a ricevere questo errore, contattare l'amministratore di Tableau Server.)

Cause

Potrebbe verificarsi un errore durante l'individuazione di un ticket non scaduto se i dati richiesti non sono stati inclusi nella richiesta HTTP per Tableau Server. Per impostazione predefinita, verrà utilizzato un sito "predefinito" se non è specificato target_site.
Risoluzione
Verifica che le richieste HTTP POST e GET utilizzate dal client o dall'applicazione Web includano tutti i valori richiesti da Tableau Server per riscattare correttamente un ticket attendibile, come Username=<nomeutente>, target_site=<ID sito> e client_ip=<indirizzo IP> (facoltativo).

Opzione 1: Errore nella creazione di un ticket seguito da un tentativo di riscossione di un ticket errato (probabilmente -1)
Verifica per assicurarti che venga generato e riscosso un numero di ticket valido.Se viene generato un ticket con valore -1, consulta https://onlinehelp.tableau.com/current/server/it-it/trusted_auth_trouble_1return.htm per i passaggi successivi.

Opzione 2: Duplica le chiamate per lo stesso numero di ticket:
Per determinare se i proxy stanno inviando più richieste per lo stesso ticket, verifica la cartella HTTPD dei log Tableau Server. Per ulteriori informazioni, vedere Posizioni dei file log.  

Per questo ticket devi vedere una sola richiesta, dove "/trusted/" è seguito da una stringa alfanumerica da 9 a 255 caratteri (il valore predefinito è 24) Se visualizzi questa informazione più di una volta, un proxy sta richiedendo più volte l'URL con il ticket, come nella prima e nella terza riga nell'esempio seguente:
1.23.45.567 - - 2016-08-09 15:52:54.348 Pacific Daylight Time 80 "GET /trusted/bTf1vpt-xdncVZw4B5nmi1Np/views/viewname/dashboardname?:embed=y&:host_url=http://12.34.56.789/&:tabs=no&:toolbar=no&:loadOrderID=0 HTTP/1.1" "1.23.45.678" 321 - "-" 31200 UctMZgq1CGoAABrYHjwAAAAM
 
123.45.67.891 - - 2016-08-09 15:52:56.578 Pacific Daylight Time 80 "GET /trusted/4wphmumvWTkVw5Rl1UrSqxqv/views/viewname/dashboard name?:embed=y&:host_url=http://12.34.56.789/&:tabs=no&:toolbar=no&:loadOrderID=0 HTTP/1.1" "123.45.67.123" 432 1234 "-" 0 UctMmQq1CGoAABrYHkEAAAB0
 
123.45.678.91 - - 2016-08-09 15:52:58.213 Pacific Daylight Time 80 "GET /trusted/bTf1vpt-xdncVZw4B5nmi1Np/views/viewname/dashboardname?:embed=y&:host_url=http://12.34.56.789/&:tabs=no&:toolbar=no&:loadOrderID=0 HTTP/1.1" "123.45.67.123" 432 1234 "-" 15600 UctMxwq1CGoAABrYHkIAAAB0
 
Per risolvere questo problema, procedi come segue

Nota: Apportare le seguenti modifiche fa sì che Tableau Server rifiuti i GET in ingresso da client non previsti, come proxy e altri scanner di sicurezza, in modo che solo il browser client specificato possa riscattare il ticket.
  1. Attiva la protezione IP del client per assicurarsi che il browser specificato abbia la possibilità di riscattare il ticket attendibile prima che il proxy riscatti il ticket. Per ulteriori informazioni, vedi l'argomento Facoltativo: Configurare la corrispondenza IP del client nella guida dell'amministratore di Tableau Server.
  2. Accertati che l'indirizzo IP del browse client sia incluso nella richiesta POST originale a Tableau Server. Per ulteriori informazioni sulle richieste POST, vedi la sezioneOttieni un ticket da Tableau Server della guida prodotto.

Opzione 3: Nessuna chiamata duplicata per ticket e URL troncata:
Se la vista incorporata è correttamente in corso di inizializzazione, l'URL non passerà attraverso la chiamata GET. Dopo il ticket attendibile, deve essere presente un URL che include il nome della vista, ma risulta mancante dalla voce di log sotto riportata:
 
123.45.678.91- - 2016-08-09 15:52:58.213 Pacific Daylight Time 443 "GET /trusted/w5DCZZDNtI8K42kzg7OyAM3p/ HTTP/1.1" "-" 403 1774 "-" 15649 V6pCqgoIAEQAADoYq48AAAIy 

Per risolvere questo problema, verifica che l'URL utilizzato per incorporare la vista non includa il segno #. Vedi Visualizzare la vista con il ticket per ulteriori informazioni. Il segno # non passa l'URL completo causando un errore nel riscatto del ticket.
  • URL del ticket attendibile creato in modo errato: http://myserver/trusted/<ticket>/#/views/<workbook>/<view>
  • URL del ticket attendibile creato in modo corretto: http://myserver/trusted/<ticket>/t/<site>/views/<workbook>/<view>
  • URL del ticket attendibile creato in modo corretto: http://myserver/trusted/<ticket>/views/<workbook>/<view>
Nota: se Tableau Server sta eseguendo più siti e la vista si trova su un sito diverso da quello predefinito, è necessario aggiungere t/<site ID> al percorso. Vedi Cos'è un sito? per maggiori informazioni.
Risorse aggiuntive
Alcuni motivi per cui si è verificato un problema durante la richiesta di un ticket ed è stato ricevuto un valore di ticket non valido.
  • Il ticket attendibile non è stato usato entro tre minuti.
  • Un proxy ha inviato richieste di duplicazione a Tableau Server e ha inavvertitamente riscattato il ticket che si trovava nell'URL, invalidandolo per le richieste successive.
  • L'URL incorporato è errato, troncando l'URL completo della vista. Questo errore è stato ottenuto anche quando il codice del ticket attendibile ha utilizzato il server errato per creare la richiesta GET.



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