Loading

Errori "Function ... returned error (50019, 41141, 22)" o "No License found" durante l'attivazione

Data pubblicazione: Jul 20, 2023
Descrizione
Quando tenti di eseguire l'attivazione offline, potrebbe essere visualizzato il seguente errore nella riga di comando:

*** com.tableausoftware.license.dll.ActivationException: Function flxActSvrActivationRespProcess returned error (50019, 41141, 22)

LM_TS_PROCESS_RESP
Your request could not be completed because the FlexNet Licensing Service could not process a response. Try reinstalling Tableau Desktop or Tableau Server. The FlexNet Licensing Service could not process a response because no outstanding request was found. Try reinstalling Tableau Desktop or Tableau Server. (La richiesta non ha potuto essere completata perché il servizio licenze FlexNet non è stato in grado di elaborare una risposta. Prova a reinstallare Tableau Desktop o Tableau Server. Il servizio licenze FlexNet non ha potuto elaborare una risposta perché non è stata trovata alcuna richiesta in sospeso. Prova a reinstallare Tableau Desktop o Tableau Server.)

O

*** com.tableausoftware.license.ddl.ActivationException:
Function flxActSvrActivationRespProcess returned error(50020, 42054, 10247) 

LM_TS_UNKNOWN_RESP

Quando provi a eseguire l'attivazione online, potrebbe verificarsi il seguente errore:

No License found for 'TableauServer' (Nessuna licenza trovata per "TableauServer")

Cause

Questo errore spesso si verifica quando il file activation.tlf è stato utilizzato più di una volta, viene utilizzato sul computer errato o è danneggiato.
Risoluzione

Importante: Il file activation.tlf può essere utilizzato una sola volta e non può essere usato su un computer diverso da quello per cui è stato creato.


Passaggio 1

  1. In Esplora risorse di Windows, passa alla directory bin di Tableau Server. Ad esempio:
    • Su un computer a 32 bit: cd "C:\Program Files\Tableau\Tableau Server\<version>\bin"
    • Su un computer a 64 bit: cd "C:\Program Files (x86)\Tableau\Tableau Server\<version>\bin"
  2. Verifica che la directory bin di Tableau Server contenga un solo file activation.tlf. Se la directory contiene più di un file activation.tlf, elimina tutte le istanze precedenti del file per utilizzare il file activation.tlf corrente.
  3. Attiva Tableau Server.

Passaggio 2

  1. Se i passaggi precedenti non risolvono il problema, crea nuovi file offline.tlq e activation.tlf.
  2. Attiva Tableau Server utilizzando il nuovo file activation.tlf. Per ulteriori informazioni, consulta Attivazione di Tableau offline

Passaggio 3

Risorse aggiuntive

Numero articolo Knowledge

001473707

 
Caricamento
Salesforce Help | Article