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Les filtres ou les commandes de paramètres disparaissent après la publication

Date de publication: Jul 20, 2023
Description
Après la publication d'un classeur sur Tableau Server, il se peut que certains utilisateurs ne voient pas les filtres ou les commandes de paramètres lors de l'affichage du classeur dans un navigateur. Une zone grise peut s'afficher à la place du filtre ou de la commande de paramètre.

Cause

  • Le filtre dans le tableau de bord n'est pas considéré comme valide parce qu'il n'est associé à aucune feuille.
  • La commande de paramètre ou le filtre n'est pas dans un état valide et doit être configuré sur un état valide pour afficher un rendu approprié.
  • Certains utilisateurs ne disposent pas des autorisations appropriées pour voir le filtre.
  • Le filtre n'est pas inclus dans la disposition du périphérique d'affichage.
Résolution

Si aucun utilisateur ne peut voir les filtres ou les commandes de paramètres :

Dans Tableau Desktop, ajoutez le(s) filtre(s) et les commande(s) de paramètre aux feuilles souhaitées utilisées dans le tableau de bord.
Si cela ne fonctionne pas, recherchez les commandes de paramètres ou les filtres utilisateur n'affichant pas de rendu dans Tableau Desktop. Recherchez les paramètres qui ne font pas sens, par exemple une commande de paramètre défini pour autoriser « Toutes » les valeurs pour lesquelles « Saisir au clavier » n'est pas activé. Si vous voyez quelque chose s'afficher, modifiez les paramètres de la commande ou du filtre et republiez.

Si certains utilisateurs peuvent voir les filtres ou les commandes de paramètres, et d'autres non :

Assurez-vous que toutes les dispositions de périphériques pour le tableau de bord contiennent les filtres ou les commandes de paramètres souhaités qui leur sont associés.

Pour les utilisateurs qui ne sont pas en mesure d'afficher les filtres, prenez les mesures suivantes en tant qu'administrateur de Tableau Server :
  1. Définir le rôle sur le site de l'utilisateur sur Interacteur. Pour plus d'informations, consultez Définir les autorisations tandis que vous publiez une source de données ou un classeur dans l'aide de Tableau.
  2. Vérifier les autorisations pour cet utilisateur sur le projet, ou la vue elle-même. L'autorisation Filtre doit être définie sur Autoriser. Pur plus d'informations, consultez Autorisations et Rôles prédéfinis que vous pouvez attribuer dans l'aide de Tableau.
  3. Affecter une autorisation à un contenu au niveau du projet.
    • Connectez-vous à Tableau Server en tant qu'administrateur, puis accédez à Admin > Projets.
    • Cochez la case en regard du projet approprié, puis cliquez sur Autorisations.
    • Cliquez sur Affecter des autorisations au contenu. Une fois que vous avez terminé, cliquez sur Quitter.
Numéro d’article de la base de connaissances

001473713

 
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Salesforce Help | Article