Loading

Le tableau de bord est vide ou il y manque du contenu après avoir publié sur Tableau Server ou Tableau Cloud à l'aide de dispositions pour les appareils

Date de publication: Apr 24, 2024
Description
Après que vous avez publié le classeur qui contient les dispositions pour les appareils sur Tableau Server ou Tableau Cloud, le tableau de bord ou la vue apparaît vide, ou diffère de la vue qui s'affichait dans Tableau Desktop.

Cause

Des dispositions alternatives peuvent être ajoutées par erreur, ou différer de la disposition « Par défaut » dans Tableau Desktop. Si tel est le cas et que vous affichez le classeur publié sur cet appareil spécifique à cette disposition, l'aspect du classeur sera différent de son aspect dans Tableau Desktop en cas d'affichage sur Tableau Server ou Tableau Cloud. Ceci se produit uniquement si le contenu actuel est différent de cette disposition par rapport à la disposition des vues par défaut pour le contenu (par exemple des vues vides ou manquantes).
 
Résolution
  1. Ouvrez le classeur dansTableau Desktop.
  2. Vérifiez qu'il existe des dispositions alternatives (Tablette, Téléphone ou Ordinateur de bureau) en plus de votre disposition par défaut.
  3. Cliquez sur toutes les dispositions pour voir si une disposition se différencie de la disposition par défaut.
  4. Supprimez ou mettez à jour la disposition (Tablette, Téléphone ou Ordinateur de bureau) qui est différente de la vue par défaut, afin qu'elle corresponde à la vue par défaut.
  5. Republiez le classeur sur le classeur concerné pour le mettre à jour et corriger le problème.
 

Comme décrit dans l'image ci-dessous, la disposition « Ordinateur de bureau » est différente de la disposition « Par défaut » et n'a pas de contenu. De ce fait, lorsqu'elle est publiée sur Tableau Server ou Tableau Cloud et affichée sur un ordinateur de bureau, la vue apparaît vide. La vue Tableau Desktop comportant un contenu est supprimée par accident ou est différente :

Disposition par défaut

Après avoir cliqué sur l'option de vue Par défaut, vous verrez normalement la vue ou le tableau de bord par défaut dans Tableau Desktop :

Disposition par défaut

Une fois que le classeur est publié sur Tableau Server ou Online, la vue Ordinateur de bureau est la vue que Tableau Server ou Tableau Cloud affiche par défaut, et le résultat est une vue vide. Si le contenu est différent dans cette vue, il apparaît différent, ou il manque un contenu tel que des filtres ou des données dans Tableau Server ou Tableau Cloud selon l'appareil utilisé pour le consulter.

Ressources supplémentaires
Remarque : cet article concerne uniquement le problème de tableau de bord vide causé par la disposition alternative. Un tableau de bord ou une vue peuvent apparaître vides pour différentes raisons.  
Une vue peut apparaître vide après publication si un classeur est publié depuis une version récente de Tableau Desktop vers une version plus ancienne de Tableau Server. Si les fonctionnalités utilisées dans la version récente de Tableau Desktop n'existent pas dans la version plus ancienne de Tableau Server, la vue ne s'affiche pas.
Option 1 : exportez le classeur vers une version compatible de Tableau Desktop et publiez-le depuis une version Tableau Desktop compatible.
Option 2 : effectuez la mise à niveau Tableau Server vers une nouvelle version compatible avec Tableau Desktop

D'autres situations peuvent également s'appliquer :

La vue est vide après publication d'une vue avec un filtre qui utilise une fonction de nom d'utilisateur
Un objet Page Web lié à une URL Web est vide après la publication
Un objet Page Web lié à un fichier local est vide après la publication
Des feuilles de tableau de bord apparaissent vides lors de l'utilisation des filtres rapides
 
Numéro d’article de la base de connaissances

001473723

 
Chargement
Salesforce Help | Article