Loading

La dashboard è vuota o manca del contenuto dopo la pubblicazione su Tableau Server o Tableau Cloud tramite i layout di dispositivo

Data pubblicazione: Apr 24, 2024
Descrizione
Dopo aver pubblicato la cartella di lavoro che contiene layout di dispositivo su Tableau Server o Tableau Cloud, la dashboard o la vista sembrano vuote o presentano un aspetto diverso rispetto a quando sono visualizzate in Tableau Desktop.

Cause

Potresti aver inserito erroneamente dei layout alternativi o che si discostano da quello "predefinito" in Tableau Desktop. Se questo è il caso e visualizzi la cartella di lavoro pubblicata sul dispositivo specifico per tale layout, la cartella di lavoro avrà un aspetto diverso da quello visualizzato in Tableau Desktop quando aperta in Tableau Server o Tableau Cloud. Questo problema si verifica solo se l'effettivo contenuto differisce nel layout se confrontato con il layout di visualizzazione predefinito dei contenuti (ad esempio, viste vuote o parzialmente mancanti).
 
Risoluzione
  1. Apri la cartella di lavoro in Tableau Desktop.
  2. Verifica la presenza di layout alternativi (Tablet, Telefono o Desktop) oltre al layout predefinito.
  3. Fai clic e scorri i layout per cercarne uno che si differenzia da quello predefinito.
  4. Rimuovi o aggiorna il layout (Tablet, Telefono o Desktop) diverso dalla vista predefinita, in modo che corrisponda.
  5. Pubblica nuovamente la cartella di lavoro sovrascrivendo la cartella di lavoro interessata per aggiornarla e correggere il problema.
 

Come descritto nell'immagine precedente, il layout "Desktop" è diverso da quello "Predefinito" e non include contenuti. Di conseguenza, quando si pubblica su Tableau Server o Tableau Cloud e si visualizza da un computer Desktop, la vista appare vuota. La vista di Tableau Desktop con contenuti accidentalmente rimossi o diversi:

Layout predefinito

Dopo aver fatto clic sull'opzione di visualizzazione predefinita, visualizzerai in genere la vista predefinita o la dashboard in Tableau Desktop:

Layout predefinito

Dopo aver pubblicato una cartella di lavoro su Tableau Server o Online, la vista Desktop è quella predefinita in Tableau Server o Tableau Cloud, che come risultato appare vuota. Se i contenuti della vista sono diversi, hanno un aspetto diverso o alcuni elementi risultano mancanti (come filtri o dati) in Tableau Server o Tableau Cloud, dipende dal dispositivo usato per visualizzarli.

Risorse aggiuntive
Nota: questo articolo riguarda solo il problema della dashboard vuota a causa del layout alternativo. Sono diversi i motivi per i quali una dashboard/vista può apparire vuota.  
La vista vuota dopo la pubblicazione può verificarsi anche quando la cartella di lavoro viene pubblicata a partire da una versione più nuova di Tableau Desktop in una versione meno recente di Tableau Server. Se le funzionalità utilizzate nella versione più recente di Tableau Desktop non esistono nella versione meno recente di Tableau Server, la vista non viene visualizzata.
Opzione 1: esporta la cartella di lavoro in una versione compatibile di Tableau Desktop e pubblica da una versione compatibile di Tableau Desktop
Opzione 2: aggiorna Tableau Server a una versione nuova che sia compatibile con Tableau Desktop

Esistono altri casi:

La vista è vuota dopo aver pubblicato una vista con un filtro tramite una funzione Username
Oggetto della pagina Web collegato all'URL Web vuoto dopo la pubblicazione
Oggetto della pagina Web collegato al file locale vuoto dopo la pubblicazione
I fogli della dashboard appaiono vuoti quando si utilizzano i filtri rapidi
 
Numero articolo Knowledge

001473723

 
Caricamento
Salesforce Help | Article