Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

デバイス レイアウトを使用した Tableau Server または Tableau Cloud へのパブリッシュ後にダッシュボードが空白になるか内容が欠落する

公開日: Apr 24, 2024
説明
デバイス レイアウトを含むワークブックの Tableau Server または Tableau Cloud へのパブリッシュ後、ダッシュボードまたはビューが空白で表示されたり、Tableau Desktop での表示と異なって表示されたりします。

Cause

代替レイアウトが誤って追加されたか、または Tableau Desktop の既定のレイアウトと異なる可能性があります。その場合、パブリッシュされたワークブックをそのレイアウトに固有のデバイスで表示すると、Tableau Server または Tableau Cloud で表示したときにワークブックが Tableau Desktop とは異なる表示になります。これは、コンテンツの既定ビューのレイアウトと比べて実際のコンテンツがレイアウト内で異なっている場合にのみ発生します (空白または一部のビューの欠落など)。
 
解決策
  1. Tableau Desktop でワークブックを開きます。
  2. [デフォルト] レイアウトに加えて代替レイアウト ([タブレット]、[スマートフォン]、または [デスクトップ]) があるかどうか確認します。
  3. すべてのレイアウトを一通りクリックし、デフォルトのレイアウトと異なるレイアウトがあるかどうか確認します。
  4. デフォルトのビューと一致するように、デフォルトのビューと異なるレイアウト ([タブレット]、[スマートフォン]、または [デスクトップ]) を削除または更新します。
  5. 影響を受けるワークブックについて、ワークブックを更新して問題を修正するためにワークブックをもう一度パブリッシュします
 

以下の図のとおり、[デスクトップ] レイアウトは [デフォルト] レイアウトと異なり、コンテンツが含まれていません。したがって、ワークブックを Tableau Server または Tableau Cloud にパブリッシュして Desktop マシンで表示すると、ビューが空白として表示されます。以下の Tableau Desktop ビューはコンテンツを含みますが、誤って削除されたか、間違って表示されています。

既定のレイアウト

[デフォルト] ビュー オプションをクリックすると、Tableau Desktop でデフォルトのビューまたはダッシュボードが正常に表示されます。

既定のレイアウト

Tableau Server または Online へのワークブックのパブリッシュ後、Desktop ビューが Tableau Server または Tableau Cloud の既定のビューとなり、その結果、空白として表示されます。そのビューのコンテンツが異なる場合、使用するデバイスによって異なって表示されたり、Tableau Server または Tableau Cloud のフィルターやデータなどのコンテンツが欠落したりします。

その他のリソース
注: この記事は代替レイアウトのためにダッシュボードが空白になる問題にのみ対処しています。ダッシュボードやビューが空白で表示されることがある理由は多数あります。  
パブリッシュ後の空白のビューは、新しいバージョンの Tableau Desktop から古いバージョンの Tableau Server にワークブックがパブリッシュされた場合にも発生する可能性があります。Tableau Desktop の新しいバージョンで使用されている機能が、古いバージョンの Tableau Server に存在しない場合、ビューは表示されません。
オプション 1: ワークブックを互換バージョンの Tableau Desktop にエクスポートし、互換性のある Tableau Desktop からパブリッシュします
オプション 2: Tableau Server を Tableau Desktop と互換性のある新しいバージョンにアップグレードします

他に該当する可能性があるケースがあります。

ユーザー名関数を使用したフィルターを含むビューをパブリッシュした後にビューが空白である
パブリッシュ後に Web ベースの URL にリンクされた Web ページ オブジェクトが空白である
パブリッシュ後にローカル ファイルにリンクされた Web ページ オブジェクトが空白である
クイック フィルターの使用時にダッシュボードのシートに何も表示されない
 
ナレッジ記事番号

001473723

 
読み込み中
Salesforce Help | Article