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Error "Login timeout expired" al actualizar una extracción

Fecha de publicación: Jul 20, 2023
Descripción
Al intentar actualizar un extracto, es posible que se muestre uno de los errores siguientes:

com.tableausoftware.nativeapi.dll.DataSourceException: SQL Server database error 0x80004005: Login timeout expired (com.tableausoftware.nativeapi.dll.DataSourceException: Error de base de datos de SQL Server 0x80004005: caducó el tiempo de espera de inicio de sesión)
SQL Server database error 0x80004005: A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online. (Error de base de datos de SQL Server 0x80004005: se produjo un error relacionado con la red o específico de una instancia al establecer una conexión con SQL Server. No se encuentra el servidor o no es accesible. Compruebe si el nombre de la instancia es correcto y si SQL Server está configurado para permitir las conexiones remotas. Para obtener más información, consulte Libros en pantalla de SQL Server).

SQL Server database error 0x80004005: Named Pipes Provider: Could not open a connection to SQL Server [53]. (Error de base de datos de SQL Server 0x80004005: proveedor de canalizaciones con nombre: no se pudo establecer una conexión con SQL Server [53]).
Unable to connect to the server "ServerName". Check that the server is running and that you have access privileges to the requested database. (Unable to connect to the server "server name". Compruebe que el servidor esté en ejecución y que disponga de privilegios de acceso a la base de datos solicitada).

Cause

Este problema se origina en la base de datos de SQL Server, no desde Tableau Server, y está causado por problemas de comunicación de red con SQL Server. Este error se puede producir por diferentes motivos, como los siguientes ejemplos: 
  • La configuración de canalizaciones con nombre suele producir paquetes perdidos sin notificación, lo que evita que Tableau Server pueda conectarse al equipo donde se ejecuta SQL Server.
  • Si el equipo donde se ejecuta SQL Server y el equipo donde se ejecuta Tableau Server se unen de diferentes dominios y SQL Server usa la autenticación de Active Directory, si se obtiene acceso de forma remota al equipo donde se ejecuta SQL Server (por ejemplo, a través de Escritorio remoto), se pueden producir problemas.
  • Las credenciales y los parámetros de conexión especificados en el diálogo de conexión de datos de SQL Server son incorrectos.
Solución
Trabaje con el administrador de la base de datos de SQL Server para solucionar problemas de conexión de red.

A continuación se muestra una lista de sugerencias que pueden ayudarle a solucionar el problema:
  • Si el equipo donde se ejecuta Microsoft SQL Server usa el protocolo de cliente Canalizaciones con nombre, configure Microsoft SQL Server para usar TCP/IP en su lugar.
  • En el equipo donde se ejecute Tableau Server, inicie sesión como administrador y asegúrese de que puede conectarse a la base de datos de SQL Server desde Microsoft Excel o desde SQL Server Management Studio. Si la conexión es correcta, asegúrese de que usa los mismos parámetros de conexión y credenciales en el diálogo de conexión de datos de SQL Server en Tableau Server o en Tableau Desktop.
  • Si el equipo que ejecuta SQL Server y el equipo donde se ejecuta Tableau Server se unen de distintos dominios y SQL Server usa la autenticación de Active Directory, cree un usuario local de SQL Server y, a continuación, use las credenciales de usuario locales de SQL Server para conectarse a SQL Server a través de Tableau Server.
Recursos adicionales
Para obtener información sobre las diferencias entre el uso de TCP/IP y canalizaciones con nombre en Microsoft SQL Server, consulte el tema Canalizaciones con nombre y sockets TCP/IP en MSDN.
Número del artículo de conocimiento

001473736

 
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