Loading

Erreur "Login timeout expired" lors de l'actualisation de l'extrait

Date de publication: Jul 20, 2023
Description
Lorsque vous tentez d'actualiser un extrait, l'une des erreurs suivantes peut se produire :

com.tableausoftware.nativeapi.dll.DataSourceException: Erreur au niveau de la base de données SQL Server 0x80004005 : Expiration du délai de connexion
Erreur au niveau de la base de données SQL Server 0x80004005 : Une erreur liée au réseau ou spécifique à une instance s'est produite lors de l'établissement d'une connexion à SQL Server. Serveur introuvable ou inaccessible. Vérifiez si le nom de l'instance est correct et si SQL Server est configuré pour autoriser les connexions distantes. Pour plus d'informations, consultez SQL Server Books Online.

Erreur au niveau de la base de données SQL Server 0x80004005 : Fournisseur des canaux nommés :Impossible d'ouvrir une connexion à SQL Server [53].
Unable to connect to the server "ServerName". Check that the server is running and that you have access privileges to the requested database. (Impossible de se connecter au serveur "ServerName". Vérifiez que le serveur est en cours d'exécution et que vous disposez de privilèges d'accès à la base de données demandée.)

Cause

Le problème provient de la base de données SQL Server, non de Tableau Server, et est dû à des problèmes de communication avec SQL Server. L'erreur peut se produire pour diverses raisons, et notamment :
  • La configuration des canaux nommés entraîne souvent l'abandon de paquets sans notification, ce qui empêche Tableau Server de se connecter à l'ordinateur exécutant SQL Server.
  • Si l'ordinateur exécutant SQL Server et l'ordinateur exécutant Tableau Server sont associés à des domaines différents et que SQL Server utilise l'authentification Active Directory, l'accès de l'ordinateur exécutant SQL Server à distance (par exemple via le Bureau distant) peut entraîner des problèmes.
  • Les paramètres de connexion et les informations d'identification entrés dans la boîte de dialogue Connexion de données SQL Server sont incorrects.
Résolution
Faites appel à l'administrateur de base de données SQL pour résoudre les problèmes de connexion réseau.

Voici une liste de suggestions susceptibles de vous aider à résoudre le problème :
  • Si l'ordinateur exécutant Microsoft SQL Server utilise le protocole client Canaux nommés, configurez Microsoft SQL Server de manière à utiliser TCP/IP à la place.
  • Sur l'ordinateur exécutant Tableau Server, connectez-vous en tant qu'administrateur et vérifiez que vous pouvez vous connecter à la base de données SQL Server depuis Microsoft Excel ou SQL Server Management Studio. Si la connexion est correctement établie, veillez à utiliser les mêmes paramètres de connexion et informations d'identification dans la boîte de dialogue Connexion de données SQL Server dans Tableau Server ou Tableau Desktop.
  • Si l'ordinateur exécutant SQL Server et l'ordinateur exécutant Tableau Server sont associés à différents domaines et que SQL Server utilise l'authentification Active Directory, créez un utilisateur SQL Server local puis utilisez les informations d'identification de l'utilisateur SQL Server local pour vous connecter à SQL Server via Tableau Server.
Ressources supplémentaires
Pour des informations sur les différences entre l'utilisation de TCP/IP et les canaux nommés dans Microsoft SQL Server, consultez Named Pipes vs. TCP/IP Sockets sur MSDN.
Numéro d’article de la base de connaissances

001473736

 
Chargement
Salesforce Help | Article