Loading

El filtro Rango de fechas no muestra un extremo del rango.

Fecha de publicación: Aug 24, 2022
Descripción
Al usar un filtro de rango de fecha continua, se respeta la granularidad de los datos subyacentes, incluso cuando la granularidad especificada es mayor.

Por ejemplo, si la fecha de la vista se establece a nivel mensual, y el usuario selecciona "Enero" como fecha de inicio en el filtro de rango de fechas, entonces la vista filtrará "Enero".

Cause

La selección del filtro está agrupada. Por lo tanto, al seleccionar "Enero" en lugar de "1 de enero", según los datos, la vista que se muestra incluye febrero.
Solución
Opción 1: Use parámetros para filtrar la vista
Cree un filtro que utilice un parámetro de fecha de inicio y finalización. Luego, reemplace el filtro original por el nuevo.

Crear un filtro para fechas de inicio y finalización mediante el uso de parámetros 
https://help.salesforce.com/s/articleView?id=creating-a-filter-for-start-and-end-dates-parameters&type=1&language=en_US


Opción 2: Filtre la vista con un campo calculado cuya parte de la fecha sea un año
En el libro de trabajo de ejemplo adjunto, se usa el conjunto de datos de ejemplo Superstore para realizar una demostración de las instrucciones siguientes:

1. Cree un campo calculado llamado "Año de fecha de pedido" con un cálculo similar al siguiente:

AÑO( [Fecha de pedido] )

2. Haga clic en el botón derecho en [Año de fecha de pedido] en el panel de datos y seleccione Convertir a continuo.

3. Arrastre [Año de fecha de pedido] al estante Filtros.

4. Haga clic en Aceptar para cerrar la ventana de diálogo Filtro

5. Haga clic con el botón derecho en [Año de fecha de pedido] en el estante de filtros y seleccione Mostrar filtro.

Tenga en cuenta que esta solución funciona con el nivel de fecha de año porque los años que se consideran números enteros siguen el mismo orden que los años que se consideran fechas.
Número del artículo de conocimiento

001473747

Archivos adjuntos

Continuous Year Interval Filter.twbx

1203 KB

 
Cargando
Salesforce Help | Article