Loading

Error "The table "[Extract].[Extract]" does not exist. Unable to connect to the file "<filepath>"

Julkaisupäivä: Apr 7, 2026
Kuvaus
When you open a workbook connected to an extract, the following error might occur:

Tableau Data Engine Error: 4: SimpleDatabase::SelectMetadataName: expected found=1, actual found=0 (fk=1xxxxxx name="xxx" nameTable="xxx")
The table "[Extract].[Extract]" does not exist.

Unable to connect to the file "<filepath>". Check that the file exists and that you have sufficient access privileges for it.

Cause

The extract was corrupted.
Ratkaisu
In Tableau Server:
Fix the extract issue in Tableau Desktop and republish the workbook to the server.

In Tableau Desktop:
  1. Click OK in the error message dialog box.
  2. When you are prompted to Edit the connection, click Yes.
  3. Select Regenerate the extract and then click OK.

For more information, see Use Extracts.

Lisäresurssit

Knowledge-artikkelin numero

001473767

 
Ladataan
Salesforce Help | Article