Loading

Fehler "Field ... does not exist" bei der Verbindung zu Salesforce

Veröffentlichungsdatum: Aug 24, 2022
Beschreibung
Beim Herstellen einer Verbindung zu Salesforce über Tableau Desktop führt die Auswahl des Felds "Konten" manchmal zu folgendem Fehler:

Beim Kommunizieren mit der Datenquelle '<Name der Datenquelle>' ist ein Fehler aufgetreten.
Das Feld '[Konto].[<Feldname>]', das in einer Join-Klausel enthalten ist, ist nicht vorhanden.

Cause

Option 1

Tableau Desktop bestimmt die Standardverbindungen im Voraus, da die meisten Salesforce-Konten gemeinsam denselben Satz an Objekten verwenden.Dieser Fehler tritt auf, wenn das Salesforce-Konto angepasst wurde und die durch Tableau Desktop im Voraus bestimmten Namen nicht mit den Namen im Salesforce-Konto übereinstimmen.

Option 2

Das Benutzerprofil verfügt nicht über die Berechtigung für die Anzeige des Felds.
Lösung
Durch eine der folgenden Lösungen kann das Problem in Abhängigkeit zur eigentlichen Ursache gelöst werden.

Option 1: Bearbeiten Sie die in der Standardverbindung verwendete Verknüpfung.

  1. Schließen Sie Schritt 1 und Schritt 2 im Dialogfeld "Salesforce-Verbindung" ab.
  2. Wählen Sie in Schritt 3 die Option Mehrere Tabellen aus.
  3. Wählen Sie in der Tabelle der Join-Klauseln die in der Fehlermeldung angezeigte Join-Klausel aus und klicken Sie dann auf Entfernen.
Salesforce Connection

Option 2: Überarbeiten von Berechtigungen

Arbeiten Sie mit Ihrem Salesforce-Administrator zusammen, um Ihrem Benutzerkonto die Berechtigung für das Anzeigen des Felds zu gewähren.
Nummer des Knowledge-Artikels

001473780

 
Laden
Salesforce Help | Article