Loading

Erreur "Field ... does not exist" lors de la connexion à Salesforce

Date de publication: Aug 24, 2022
Description
Lorsque vous vous connectez à Salesforce depuis Tableau Desktop, la sélection du champ Comptes dans la boîte de dialogue de connexion entraîne parfois l'erreur suivante :

Une erreur s'est produite lors de la communication avec la source de données '<nom de la source de données>'
Le champ '[Compte].[<nom du champ>]', qui est inclus dans une clause de jointure, n'existe pas.

Cause

Option 1

Tableau Desktop détermine au préalable les connexions standard, parce que la plupart des comptes Salesforce partagent le même ensemble de base d'objets.Cette erreur se produit lorsque le compte Salesforce a été personnalisé, et que les noms prédéterminés par Tableau Desktop ne correspondent pas aux noms dans le compte Salesforce.

Option 2

Le profil d'utilisateur n'est pas autorisé à afficher le champ.
Résolution
Selon la cause du problème, l'une des solutions suivantes peut résoudre le problème.

Option 1 : Modifier la jointure utilisée dans la connexion standard.

  1. Effectuez l'étape 1 et l'étape 2 dans la boîte de dialogue de connexion à Salesforce.
  2. Dans l'étape 3, sélectionnez Tables multiples.
  3. Dans la table des clauses de jointures, sélectionnez la clause de jointure qui apparaît dans le message d'erreur, puis cliquez sur Supprimer.
Connexion Salesforce

Option 2 : Réviser les autorisations

Faites appel à votre administrateur Salesforce pour accorder l'autorisation d'afficher le champ à votre compte utilisateur..
Numéro d’article de la base de connaissances

001473780

 
Chargement
Salesforce Help | Article