Loading

Errore "Field ... does not exist" durante la connessione a Salesforce

Data pubblicazione: Aug 24, 2022
Descrizione
Durante la connessione a Salesforce da Tableau Desktop, selezionando il campo Account nella finestra di dialogo di connessione, può talvolta verificarsi il seguente errore:

An error occurred while communicating with data source '<data source name>' (Si è verificato un errore durante la comunicazione con l'origine dati '<nome origine dati>')
Field '[Account].[<field name>]', which is included in a join clause, does not exist (Il campo '[Account].[<nome campo>]', incluso in una clausola join, non esiste).

Cause

Opzione 1

Tableau Desktop predetermina le connessioni standard, in quanto molti account Salesforce condividono lo stesso set base di oggetti. Questo errore si verifica quando l'account Salesforce è stato personalizzato e i nomi predeterminati da Tableau Desktop non corrispondono ai nomi nell'account Salesforce.

Opzione 2

Il profilo utente non è autorizzato visualizzare il campo.
Risoluzione
Una delle seguenti soluzioni può risolvere il problema, in base alla causa principale.

Opzione 1: Modifica il join utilizzato nella connessione standard.

  1. Completare i passaggi 1 e 2 nella finestra di dialogo Connessione Salesforce.
  2. Nel passaggio 3, selezionare Tabelle multiple.
  3. nella tabella delle clausole join, seleziona la clausola join visualizzata nel messaggio di errore, quindi fai clic su Rimuovi.
Connessione Salesforce

Opzione 2: Effettua la revisione delle autorizzazioni

Rivolgiti all'amministratore Salesforce per concedere al tuo account utente l'autorizzazione a visualizzare il campo.
Numero articolo Knowledge

001473780

 
Caricamento
Salesforce Help | Article