Loading

Tableau Server Data Engine Folder Consumes Entire Disk and Some Processes on Worker Are Down

Julkaisupäivä: Feb 26, 2025
Kuvaus
Worker machine disk space is full and Data Engine fails to start.

Cause

Tableau Server Run As user has permission to add Extracts to the Data Engine directory, but does not have permission to reap old extracts. Over time, the disk fills with unreaped extracts until all disk space is consumed and processes fail to run.
Ratkaisu
Confirm Run As User configuration:
  • Run As User permissions on impacted node
  • Services settings on impacted node
Lisäresurssit
If all disk space is consumed, it may not be possible to change permissions settings (due to a lack of disk space). In that scenario, two possible solutions are:
  • In a VM environment: add more disk space to VM image and correct permissions.
  • Remove the worker from the installation, clean re-install the worker software, confirm permissions are correct, verify that old extracts are reaped after refresh.


Knowledge-artikkelin numero

001473834

 
Ladataan
Salesforce Help | Article