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Affichage répété de l'erreur "Licensing Check In Progress"

Date de publication: Nov 29, 2023
Description
Lors de l'ouverture de Tableau Desktop ou à des intervalles de quelques heures, l'erreur suivante peut se produire :
 
Licensing Check In Progress
Tableau is still trying to determine the available licenses on your system. This task must complete before you can resume using Tableau. (Vérification des licences en cours. Tableau essaie encore de déterminer les licences disponibles sur votre système. Cette tâche doit se terminer pour que vous puissiez de nouveau utiliser Tableau.)

Cause

L'un des cas de figure suivants :
  • Tableau ou FlexNet n'était pas exécuté en tant qu'administrateur
  • Le système de surveillance des comportements interférait avec le fonctionnement de Tableau
  • Tableau Desktop ne s'est pas installé correctement
Résolution
Le message d'erreur ci-dessus peut avoir plusieurs causes. Suivez les instructions ci-dessous en commençant par l'Option 1, puis en passant à l'option suivante si l'erreur persiste.

Option 1

Assurez-vous d'exécuter Tableau Desktop en tant qu'administrateur en faisant un clic droit sur l'icône de l'application et en sélectionnant « Exécuter en tant qu'administrateur ».

Option 2

Sur l'ordinateur exécutant Tableau Desktop, cliquez sur le bouton Démarrer puis sélectionnez Tous les programmes > Accessoires > Exécuter
  1. Entrez services.msc puis cliquez sur OK.
  2. Vérifiez que le Service de licence FLEXnet ou le Service de licence FLEXnet 64 s'affiche comme « Démarré » dans la colonne État. Si FLEXnet n'apparaît pas comme « Démarré », faites un clic droit sur le nom du service puis sélectionnez Démarrer.

Option 3

Si les options 1 et 2 n'ont pas permis de résoudre le problème, essayez de réparer Trusted Storage en suivant les instructions de la section Résoudre les problèmes liés à votre installation Tableau Desktop  N° 4. Réparer Trusted Storage.

Option 4

Si l'erreur persiste, le problème vient peut-être de ce que FlexNet n'est pas exécuté en tant qu'administrateur. Assurez-vous que le service de licence est exécuté en tant qu'administrateur. Pour permettre à Tableau de s'exécuter de manière optimale, définissez l'exécutable FlexNet sur Toujours exécuter en tant qu'administrateur en procédant comme suit :
  1. Accédez à C:\Program Files\Common Files\Macrovision Shared\FlexNet Publisher
  2. Faites un clic droit sur FNPLicensingService64.exe > Propriétés > Compatibilité et cochezExécuter ce programme ent tant qu'administrateur
  3. Cliquez sur OK.

Option 5

Certains logiciels de surveillance des comportements tels que Trend Micro OfficeScan peuvent interférer avec le fonctionnement de Tableau lorsqu'ils recherchent des comportements de malware inconnus.

Adressez-vous à votre équipe de sécurité informatique pour placer Tableau et FlexNet sur la liste d'autorisations en ajoutant les processus suivants comme Programmes approuvés dans le système Surveillance de comportement :

C:\Program Files (x86)\Common Files\Macrovision Shared\FlexNet Publisher\FNPLicensingService.exe
C:\Program Files\Common Files\Macrovision Shared\FlexNet Publisher\FNPLicensingService64.exe
C:\Program Files\Tableau\Tableau <version>\bin\tableau.exe
C:\Program Files (x86)\Tableau\Tableau <version>\bin\tableau.exe
 
Remarque : remplacez « Tableau <version> » par la version de Tableau installée sur votre ordinateur, par exemple Tableau 2018.2.

Option 6

Enfin, tentez de désinstaller puis se réinstaller Tableau Desktop. Pour plus d'informations, consultez Mise à niveau de Tableau Desktop dans la base de connaissances de Tableau.

Option 7

Si aucune des étapes ci-dessus ne permet de résoudre l'erreur, veuillez contacter l'assistance technique et inclure le fichier LicResults.txt que vous avez créé dans les étapes ci-dessus sous Réparez le stockage approuvé.
 
Ressources supplémentaires
Cliquer sur Actualiser dans l'outil Gérer les clés produit peut vous permettre de continuer à travailler jusqu'à ce que l'erreur s'affiche à nouveau. Cette erreur n'empêche pas Tableau Desktop de fonctionner, mais limite sa productivité puisqu'il faut parfois jusqu'à 5 minutes pour la corriger. 


 
Numéro d’article de la base de connaissances

001473847

 
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