Loading

L'errore "Licensing Check In Progress" appare ripetutamente

Data pubblicazione: Nov 29, 2023
Descrizione
Durante l'apertura di Tableau Desktop o ogni poche ore, potrebbe verificarsi il seguente errore:
 
Licensing Check In Progress (Controllo licenza in corso)
Tableau is still trying to determine the available licenses on your system.This task must complete before you can resume using Tableau. (Tableau sta ancora cercando di determinare le licenze disponibili sul sistema. È necessario completare questa attività prima di poter riprendere a utilizzare Tableau).

Cause

Uno dei seguenti: 
  • Tableau o FlexNet non venivano eseguiti come amministratore
  • Il sistema di monitoraggio del comportamento stava interferendo con il funzionamento di Tableau
  • Installazione di Tableau Desktop non riuscita
Risoluzione
Il messaggio di errore sopra riportato può avere diverse cause. Segui le istruzioni riportate di seguito, iniziando dall'opzione 1, per poi passare all'opzione successiva se gli errori persistono.

Opzione 1

Accertati di star eseguendo Tableau Desktop come amministratore facendo clic con il tasto destro del mouse sull'icona dell'applicazione e selezionando "Esegui come amministratore".

Opzione 2

Sul computer su cui è in esecuzione Tableau Desktop, fai clic sul pulsante Start quindi seleziona Tutti i programmi > Accessori > Esegui
  1. Inserisci services.msc quindi fai clic su OK.
  2. Verifica che il Servizio di gestione licenze FLEXnet o Servizio di gestione licenze FLEXnet 64 sia elencato come "Avviato" nella colonna Stato. Se FLEXnet non è indicato come "Avviato", fai clic con il tasto destro del mouse sul nome del servizio, quindi seleziona Avvia.

Opzione 3

Se le opzioni 1 e 2 non consentono di risolvere il problema, prova a riparare l'archiviazione attendibile seguendo le istruzioni in Risoluzione dei problemi di installazione di Tableau Desktop , sezione: 4. Riparare l'archiviazione attendibile.

Opzione 4

Se il problema persiste, l'errore potrebbe essere dovuto al fatto che FlexNet non viene eseguito come amministratore. Assicurati che il Servizio licenze venga eseguito come Amministratore. Per consentire un'esecuzione ottimale di Tableau, configura l'eseguibile di FlexNet affinché venga sempre eseguito come amministratore procedendo come segue:
  1. Vai a C:\Program Files\Common Files\Macrovision Shared\FlexNet Publisher
  2. Right-click FNPLicensingService64.exe > Proprietà > Compatibilità e verifica 'Esegui questo programma come amministratore'
  3. Fai clic su OK.

Opzione 5

Alcuni software di monitoraggio del comportamento, come Trend Micro OfficeScan, possono interferire con il funzionamento di Tableau durante la ricerca di comportamenti malware sconosciuti.

Rivolgiti al team di sicurezza IT per inserire Tableau e FlexNet nell'elenco consentiti aggiungendo i seguenti processi come Programmi approvati nel sistema Monitoraggio del comportamento:

C:\Program Files (x86)\Common Files\Macrovision Shared\FlexNet Publisher\FNPLicensingService.exe
C:\Program Files\Common Files\Macrovision Shared\FlexNet Publisher\FNPLicensingService64.exe
C:\Programmi\Tableau\Tableau <versione>\bin\tableau.exe
C:\Program Files (x86)\Tableau\Tableau <versione>\bin\tableau.exe
 
Nota: sostituisci "Tableau <versione>" con la versione di Tableau installata sul tuo computer, ad esempio Tableau 2018.2.

Opzione 6

Infine, prova a disinstallare e reinstallare Tableau Desktop. Per maggiori informazioni, consulta Aggiornamento di Tableau Desktop nella Knowledge Base di Tableau.

Opzione 7

Se nessuno dei passaggi sopra riportati risolve l'errore, contatta l'Assistenza tecnica e allega il file LicResults.txt creato nel corso dei passaggi sopra riportati in Ripara archiviazione attendibile.
 
Risorse aggiuntive
Facendo clic su su "Aggiorna" nello strumento Gestisci codici prodotto è possibile continuare a lavorare, finché l'errore non viene visualizzato nuovamente. Questo errore non impedisce a Tableau Desktop di funzionare, ma può inficiarne la produttività in quanto può impiegare fino a 5 minuti per cancellarsi. 


 
Numero articolo Knowledge

001473847

 
Caricamento
Salesforce Help | Article