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Error "Licensing Check In Progress" Repeatedly Appears

Publiseringsdato: May 12, 2025
Beskrivelse

When opening Tableau Desktop, or every few hours, the following error might occur:
 

Licensing Check In Progress
Tableau is still trying to determine the available licenses on your system. This task must complete before you can resume using Tableau.
 

Cause

One of the following: 

  • Tableau or FlexNet was not being run as an administrator
  • The FlexNet license software is corrupt
  • Behavior monitoring system was interfering with Tableau's functioning 
  • Tableau Desktop did not install correctly 
Løsning

The above error message may have several causes.  Follow the instructions below starting with Option 1 and note the operating system that applies to these steps.  Test one of the options and move to the next option if the error persists.

Option 1 - MacOS

Let the software rebuild the Flexera license folders.  Run the steps in this MacOS KB article.

Option 2 - Windows

Ensure that you are running Tableau Desktop as an administrator by right-clicking the application icon and selecting ‘Run as administrator’.

Option 3 - Windows

On the computer running Tableau Desktop, click the Start button and then select All Programs > Accessories > Run

  1. Enter services.msc  and then click OK.
  2. Verify that FLEXnet Licensing Service or FLEXnet Licensing Service 64 is listed as “Started” in the Status column. If FLEXnet is not listed as “Started”, right-click the name of the service and then select Start.

 

Option 4 - Windows

Verify that FlexNet is being run with the correct permissions. Ensure the License Service is run as an Administrator. To allow Tableau to run optimally, set the FlexNet executable to always run as admin by following these steps:

  1. Navigate to C:\Program Files\Common Files\Macrovision Shared\FlexNet Publisher
  2. Right-click FNPLicensingService64.exe > Properties > Compatibility and check 'Run this program as an administrator'
  3. Click OK.

 

Option 5 - Windows

Some behavior monitoring software such as Trend Micro OfficeScan can interfere with Tableau's functioning as it looks for unknown malware behavior.

Work with your IT Security team to allowlist Tableau and FlexNet by adding the following processes as Approved Programs under the Behavior Monitoring system:

C:\Program Files (x86)\Common Files\Macrovision Shared\FlexNet Publisher\FNPLicensingService.exe
C:\Program Files\Common Files\Macrovision Shared\FlexNet Publisher\FNPLicensingService64.exe
C:\Program Files\Tableau\Tableau <version>\bin\tableau.exe
C:\Program Files (x86)\Tableau\Tableau <version>\bin\tableau.exe
 
Note: Replace "Tableau <version>" with the Tableau version installed on your computer, for example Tableau 2022.1.

 

Option 6 - Windows and MacOS

Try repairing the trusted storage by following the instructions in Troubleshoot Tableau Desktop Installation , option 4, "Repair trusted storage."   

Option 7 - Windows and MacOS

Finally, try to uninstall and re-install Tableau Desktop. For more information, see Upgrading Tableau Desktop in the Tableau Knowledge Base.

Option 8

If none of the above steps resolve the error, please contact Technical Support and include the LicResults.txt file that you created in the above steps under "Repair trusted storage."
 

Flere ressurser
Clicking 'Refresh' in the Manage Product Keys tool  may allow you to continue working until the error pops up again. This error does not prevent Tableau Desktop from working, but can inhibit productivity as it may take several minutes to clear.


 
Knowledge-artikkelnummer

001473847

 
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