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Scheduled Extract Does Not Refresh on Schedule but Can Be Run Manually in Tableau Server

Julkaisupäivä: May 9, 2025
Kuvaus

Issue

When scheduling a task, such as refreshing an extract, the task might not run as scheduled. Manually running the task or refreshing the extract can be done by using Run As User.

 

The following error might also be logged as a Background Task error:

 

com.tableausoftware.nativeapi.dll.DataSourceExceptoin: Unable to connect to the file "<file name>". Check that the file exists and that you have sufficient access privileges for it.

 

Cause

The Tableau Server Run As User has insufficient permissions to start the schedule in Tableau Server installed on Windows.

 

Ratkaisu
  1. Ensure that the Tableau Server Run As User has Modify, Read and Execute permissions for the following folders: 
    • C:\ProgramData\Tableau 
    • C:\Program Files\Tableau 
  2. Verify that the Run As User has Log on as a Service permission in the Local Security Policy.
Lisäresurssit
 



Knowledge-artikkelin numero

001473897

 
Ladataan
Salesforce Help | Article