Loading

Fehler "Could not connect to the server" bei der Verbindung mit Redshift

Veröffentlichungsdatum: Aug 24, 2022
Beschreibung
Wenn Sie versuchen, eine Verbindung zu Amazon Redshift herzustellen, tritt möglicherweise einer der folgenden Fehler auf:
 
TableauException: could not connect to the server: Connection timed out (0x0000274C/10060) Is the server running on host "<hostname>" (<IP address>) and accepting TCP/IP connections on port <port number>? Unable to connect to the server "<server name>". Check that the server is running that that you have access privileges to the requested database. (Tableau-Ausnahme: Die Verbindung zum Server konnte nicht hergestellt werden: Zeitüberschreitung der Verbindung (0x000000274C/10060) Wird der Server auf dem Host "<Hostname>" (<IP-Adresse>) ausgeführt und akzeptiert er TCP/IP-Verbindungen auf dem Port <Portnummer>? Die Verbindung zum Server "<Servername>" konnte nicht hergestellt werden. Prüfen Sie, ob der Server ausgeführt wird und ob Sie Zugriffsberechtigungen für die angeforderte Datenbank besitzen.)

Oder
 
Could not connect to the server; (Die Verbindung zum Server konnte nicht hergestellt werden;)

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (Ein Verbindungsversuch ist fehlgeschlagen, weil die verbundene Partei nach einer gewissen Zeit nicht richtig geantwortet hat, oder die hergestellte Verbindung wurde abgebrochen, weil der verbundene Host nicht geantwortet hat.)
[<IP address:Port>] ([<IP-Adresse:Port>])

Unable to connect to the server "<Redshift server name>". Check that the server is running and that you have access privileges to the requested database. (Die Verbindung zum Server "<Redhift-Servername>" konnte nicht hergestellt werden. Prüfen Sie, ob der Server ausgeführt wird und Sie über Zugriffsberechtigungen für die angeforderte Datenbank verfügen.)

Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database. (Die Verbindung zum Server konnte nicht hergestellt werden. Prüfen Sie, ob der Server ausgeführt wird und Sie über Zugriffsberechtigungen für die angeforderte Datenbank verfügen.)

Cause

Der Computer, auf dem Tableau Desktop oder Tableau Server ausgeführt wird, verfügt nicht über ausreichende Berechtigungen oder nicht über den richtigen Redshift-Treiber, oder die IP-Adresse für den Computer, auf dem Redshift ausgeführt wird, steht nicht auf der Liste der zugelassenen Adressen.
Lösung
Das Problem kann unter Umständen durch eine der folgenden Maßnahmen behoben werden:

Bei Tableau Desktop und Tableau Server

  • Arbeiten Sie mit Ihrem IT-Team zusammen, um sicherzustellen, dass der Computer mit Tableau Desktop oder Tableau Server über die entsprechenden Berechtigungen verfügt, um mit dem Computer mit Amazon Redshift zu kommunizieren.
  • Laden Sie auf dem Computer, auf dem Tableau Desktop oder Tableau Server ausgeführt wird, von der Seite Treiber und Aktivierung den Treiber für Amazon Redshift herunter und installieren Sie ihn.
  • Arbeiten Sie mit Ihrem IT-Team zusammen, um die IP-Adresse des Computers mit Tableau Desktop oder Tableau Server zu Ihrer Liste der zugelassenen Adressen in Amazon Redshift hinzuzufügen.

Für Tableau Cloud

  • Arbeiten Sie mit Ihrem IT-Team zusammen, um die IP-Adresse des Tableau Cloud-Servers zu Ihrer Liste der zugelassenen Adressen in Amazon Redshift hinzuzufügen. Weitere Informationen finden Sie im Abschnitt "IP-Adressen in Tableau Cloud-Whitelist" der Seite Daten auf dem neuesten Stand.
  • Stellen Sie sicher, dass die URL oder IP-Adresse des RedShift-Servers öffentlich zugänglich ist. Wenn die URL zu einer der folgenden IP-Adressen aufgelöst wird, ist der Server nicht öffentlich zugänglich: 10.0.0.0–10.255.255.255.
Nummer des Knowledge-Artikels

001473912

 
Laden
Salesforce Help | Article