Loading

Error "Could not connect to the server" al intentar conectar a Redshift

Fecha de publicación: Aug 24, 2022
Descripción
Cuando se intenta conectar a Amazon Redshift, podrían producirse estos errores:
 
TableauException: no se pudo conectar al servidor: La conexión ha expirado (0x0000274C/10060) ¿El servidor se ejecuta en el host "<hostname>" (<IP address>) y acepta las conexiones TCP/IP del puerto <port number>? Unable to connect to the server "<server name>". Compruebe que el servidor funciona correctamente y que tiene los permisos de acceso para la base de datos solicitada.

O
 
No se pudo conectar al servidor:

Un intento de conexión falló debido a que la parte de conexión no respondió a tiempo, o no se pudo establecer la conexión porque el host no responde.
[<IP address:Port>]

No se pudo conectar al servidor "<Redshift server name>". Check that the server is running and that you have access privileges to the requested database. (No se puede conectar con el servidor "<nombre servidor>". Compruebe que el servidor está en ejecución y que dispone de privilegios de acceso a la base de datos solicitada).

Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database. (No se puede conectar con el servidor "<nombre servidor>". Compruebe que el servidor está en ejecución y que dispone de privilegios de acceso a la base de datos solicitada).

Cause

El sistema que ejecuta Tableau Desktop o Tableau Server no tiene los permisos necesarios, no tiene el controlador de Redshift adecuado o la dirección IP del sistema que ejecuta Redshift no aparece en la lista de direcciones aprobadas.
Solución
Siga estos pasos para intentar solucionar el problema:

Para Tableau Desktop y Tableau Server

  • Contacte con su equipo de TI para comprobar que el sistema que ejecuta Tableau Desktop o Tableau Server tiene los permisos necesarios para comunicarse con el sistema que ejecuta Amazon Redshift.
  • En el sistema que ejecuta Tableau Desktop o Tableau Server, descargue e instale el controlador para Amazon Redshift desde la página Controladores y activación de Tableau.
  • Contacte con su equipo de TI para añadir la dirección IP del sistema que ejecuta Tableau Desktop o Tableau Server a la lista de direcciones aprobadas en Amazon Redshift.

Para Tableau Cloud

  • Contacte con su equipo de TI para añadir la dirección IP del servidor de Tableau Cloud a su lista de direcciones aprobadas en Amazon Redshift. Para obtener más información, consulte la sección "Lista de direcciones IP aprobadas de Tableau Cloud" de la página Mantener los datos actualizados.
  • Compruebe que la URL o la dirección IP del servidor de RedShift es accesible.Su la URL redirige a una de las siguientes direcciones IP, significa que el servidor no es accesible:10.0.0.0 – 10.255.255.255.
Número del artículo de conocimiento

001473912

 
Cargando
Salesforce Help | Article