Loading

Errore "Could not connect to the server" durante la connessione a Redshift

Data pubblicazione: Aug 24, 2022
Descrizione
Quando tenti la connessione a Amazon Redshift, potrebbe verificarsi uno dei seguenti errori:
 
TableauException: could not connect to the server: Connection timed out (0x0000274C/10060) Is the server running on host "<hostname>" (<IP address>) and accepting TCP/IP connections on port <port number>? Unable to connect to the server "<server name>". Check that the server is running that that you have access privileges to the requested database. (Timeout della connessione (0x0000274C/10060) Il server è in esecuzione sull'host "<hostname>" (<indirizzo IP>) e sta accettando le connessioni TCP/IP sulla porta <numero porta>? Impossibile connettersi al server """. Verificare che sul server in esecuzione che si disponga dei privilegi di accesso al database richiesto.).

O
 
Could not connect to the server (Impossibile connettersi al server);

A connection attempt failed because the connected party did not properly respond after a period of time or established connection failed because connected host has failed to respond. (Un tentativo di connessione non è riuscito perché la parte connessa non ha risposto correttamente dopo un periodo di tempo o la connessione stabilita non è riuscita perché l'host connesso non ha risposto.)
[<IP address:Port>] ([<Indirizzo IP:Porta>]

Unable to connect to the server "<Redshift server name>". Check that the server is running and that you have access privileges to the requested database. (Impossibile connettersi al server "<nome server>". Verificare che il server sia in funzione e che si disponga dei privilegi di accesso al database richiesto.)

Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database. (Impossibile connettersi al server "<nome server>". Verificare che il server sia in funzione e che si disponga dei privilegi di accesso al database richiesto.)

Cause

Il computer su cui è eseguito Tableau Desktop o Tableau Server non dispone delle autorizzazioni necessarie o del driver Redshift corretto, oppure l'indirizzo IP per il computer che sui cui è eseguito Redshift non è nell'elenco degli indirizzi approvati.
Risoluzione
Uno o più dei seguenti passaggi di risoluzione potrebbero risolvere il problema:

Per Tableau Desktop e Tableau Server

  • Collabora con il tuo team IT per garantire che il computer che su cui è eseguito Tableau Desktop o Tableau Server disponga delle autorizzazioni appropriate per comunicare con il computer che esegue Amazon Redshift.
  • Sul computer su cui è eseguito Tableau Desktop o Tableau Server, scarica e installa il driver Amazon Redshift dalla pagina di Tableau Driver e attivazione.
  • Collabora con il tuo team IT per aggiungere l'indirizzo IP del computer su cui è eseguito Tableau Desktop o Tableau Server all'elenco di indirizzi approvati in Amazon Redshift.

Per Tableau Cloud

  • Collabora con il tuo team IT per aggiungere l'indirizzo IP del server di Tableau Cloud all'elenco di indirizzi approvati in Amazon Redshift .Per maggiori informazioni, consulta la sezione "Indirizzi IP della whitelist di Tableau Cloud" della pagina Mantieni i dati aggiornati.
  • Assicurati che l'URL o l'indirizzo IP del server RedShift disponga di un accesso pubblico. Se l'URL si risolve in uno dei seguenti indirizzi IP, il server dispone di un accesso pubblico:10.0.0.0 – 10.255.255.255.
Numero articolo Knowledge

001473912

 
Caricamento
Salesforce Help | Article