Loading

Error "Communication link failure" o "SQLState 08501 " al actualizar una extracción

Fecha de publicación: Aug 24, 2022
Descripción
Al actualizar una extracción publicada en Tableau Server sobre Tableau Server, puede aparecer el siguiente mensaje de error:
 
com.tableausoftware.nativeapi.dll.DataSourceException: Communication link failure (com.tableausoftware.nativeapi.dll.DataSourceException: Error en el enlace de comunicación).
 
 Los archivos de registro muestran el siguiente error:
 
--- ODBC Error -------------------------------------------------------------
File:         db\ODBCProtocolImpl.cpp, Line: 2524
Error Code:   -1 (SQL_ERROR)
2338: -------------
2338: Error Record: 1
2338: Description:  'Communication link failure'
2338: SQLState:     08S01 (SQLSTATE_COMMUNICATION_LINK_FAILURE)
2338: Native Error: 14
2338: ----------------------------------------------------------------------------

Además, puede producirse el mismo error al actualizar una fuente de datos publicada desde Tableau Desktop.
 
 

Cause

El problema puede estar relacionado con una congestión de la red, con una elevada carga del servidor o con otros problemas de red o hardware.
 
Solución
Contacte con su equipo de TI para determinar si se ha interrumpido el tráfico de red, si la red está congestionada, si hay una carga elevada del servidor en la fuente de datos u otro tipo de problemas de red o hardware entre sus sistemas que causen la pérdida de la conexión.
Recursos adicionales
Para obtener más información, consulte los siguientes artículos e información:
Para las fuentes de datos de Teradata, los errores de comunicación de red pueden deberse a varios motivos. A continuación encontrará una lista de las causas habituales de los problemas de conectividad, en orden de más probable a menos probable:
  1. Teradata Viewpoint, un administrador de Teradata, PMON u otro proceso de administrador que compruebe la inactividad de la sesión y cierre las sesiones inactivas ha cerrado forzosamente la sesión de Teradata. Esto se puede comprobar examinando el directorio /var/log/messages del nodo de base de datos de Teradata en busca de mensajes que indiquen que se ha abortado una sesión. Este es un problema habitual con conexiones JDBC en cola, porque este tipo de conexiones pueden pasar mucho tiempo inactivas.El administrador de la base de datos de Teradata no debe forzar el cierre de sesiones de Teradata que sean conexiones JDBC en cola, porque eso contradice el objetivo de la cola de conexión JDBC.
  2. Problema de red o error en el tráfico de red.Esto puede incluir casos como el cambio de un portátil de una red inalámbrica a una conexión por cable (o viceversa) o la conexión o desconexión de una red VPN.
  3. El hardware de red está dañado (switch, router o equilibrador de carga).
  4. Se ha reiniciado la base de datos de Teradata.Esto se puede comprobar examinando el directorio /var/log/messages del nodo de base de datos de Teradata en busca de mensajes que indiquen que se ha reiniciado la base de datos de Teradata.
Número del artículo de conocimiento

001473913

 
Cargando
Salesforce Help | Article