Loading

Erreur "Communication link failure" ou "SQLState 08501" lors de l'actualisation d'un extrait

Date de publication: Aug 24, 2022
Description
Lors de l'actualisation d'un extrait publié sur Tableau Server dans Tableau Server, le message d'erreur suivant peut s'afficher :
 
com.tableausoftware.nativeapi.dll.DataSourceException: Communication link failure (Échec du lien de communication)
 
 Les fichiers journaux peuvent inclure l'erreur suivante :
 
--- ODBC Error-------------------------------------------------------------
File:         db\ODBCProtocolImpl.cpp, Line: 2524
Error Code:   -1 (SQL_ERROR)
2338: -------------
2338: Error Record: 1
2338: Description :  'Communication link failure'
2338: SQLState:     08S01 (SQLSTATE_COMMUNICATION_LINK_FAILURE)
2338: Native Error: 14
2338: ----------------------------------------------------------------------------

La même erreur peut également se produire lors de l'actualisation d'une source de données publiée depuis Tableau Desktop.
 
 

Cause

Le problème peut être lié à une congestion du réseau, à une charge élevée du serveur, ou à d'autres problèmes de réseau ou de matériel.
 
Résolution
Adressez-vous à votre équipe informatique pour déterminer si la perte de la connexion est causée par des interruptions du trafic réseau, une congestion du réseau, une charge élevée du serveur sur la source de données, d'autres dysfonctionnements du réseau, ou des problèmes matériels entre vos systèmes.
Ressources supplémentaires
Pour plus d'informations à ce sujet, consultez les articles suivants et les informations ci-dessous. 
Spécifiquement pour les sources de données Teradata : un problème de communication réseau peut se produire pour diverses raisons. Voici une liste des causes courantes des problèmes de connectivité, des plus probables aux moins probables :
  1. La session Teradata a été déconnectée de force par Teradata Viewpoint, Teradata Manager, PMON ou un autre processus administrateur recherchant les sessions inactives et y mettant fin. Vous pouvez vérifier le problème en recherchant, dans /var/log/messages sur le nœud de la base de données Teradata, des messages indiquant qu'une session a été abandonnée. Il s'agit d'un problème courant des connexions JDBC dans un pool de connexions, parce que les connexions JDBC dans un pool de connexions peuvent être inactives pendant une grande partie de leur durée de vie. L'administrateur de la base de données Teradata ne devrait pas déconnecter de force les sessions Teradata inactives qui sont des connexions JDBC mises en pool étant donné que cela va à l'encontre du but même du pool de connexion JDBC.
  2. Problème réseau et/ou défaillance réseau temporaire. Ceci peut se produire par exemple lorsqu'un ordinateur portable passe d'une connexion câblée à une connexion réseau sans fil (ou vice-versa), ou lors d'une connexion à un VPN/déconnexion d'un VPN.
  3. Matériel réseau défaillant, par exemple un commutateur, un routeur ou un équilibreur de charge défectueux.
  4. Un redémarrage de la base de données Teradata a eu lieu. Vous pouvez vérifier le problème en recherchant, dans /var/log/messages sur le nœud de la base de données Teradata, des messages indiquant qu'un redémarrage de la base de données Teradata a eu lieu.
Numéro d’article de la base de connaissances

001473913

 
Chargement
Salesforce Help | Article