Loading

Errore "Communication link failure" o "SQLState 08501" durante l'aggiornamento di un'estrazione

Data pubblicazione: Aug 24, 2022
Descrizione
Durante l'aggiornamento da Tableau Server di un'estrazione pubblicata su Tableau Server, potrebbe essere visualizzato il seguente messaggio di errore:
 
com.tableausoftware.nativeapi.dll.DataSourceException: Communication link failure (com.tableausoftware.nativeapi.dll.DataSourceException: errore nel collegamento di comunicazione)
 
 I file di log possono includere il seguente errore:
 
--- ODBC Error -------------------------------------------------------------
File:         db\ODBCProtocolImpl.cpp, Line: 2524
Error Code:   -1 (SQL_ERROR)
2338: -------------
2338: Error Record: 1
2338: Description:  'Communication link failure'
2338: SQLState:     08S01 (SQLSTATE_COMMUNICATION_LINK_FAILURE)
2338: Native Error: 14
2338: ----------------------------------------------------------------------------

Inoltre, lo stesso errore potrebbe verificarsi durante l'aggiornamento di un'origine dati pubblicata da Tableau Desktop.
 
 

Cause

Il problema potrebbe essere correlato alla congestione della rete, al carico elevato del server o ad altri problemi di rete o hardware. 
 
Risoluzione
Collabora con il team IT per determinare se sono presenti interruzioni del traffico di rete, congestione della rete, carico elevato del server sull'origine dati, altre interruzioni di rete o problemi hardware tra i sistemi che stanno causando la perdita della connessione.
Risorse aggiuntive
Per maggiori informazioni su questo argomento, consulta i seguenti articoli e le informazioni riportate di seguito. 
In particolare per le origini dati Teradata, un errore di comunicazione di rete può verificarsi per una serie di motivi. Di seguito è riportato un elenco delle cause comuni dei problemi di connettività, in ordine dalla più probabile alla meno probabile:
  1. La sessione Teradata è stata disconnessa forzatamente da Teradata Viewpoint, Teradata Manager, PMON o da un altro processo amministratore che verifica l'inattività della sessione e interrompe le sessioni inattive. Questo può essere verificato esaminando /var/log/messages sul nodo del database Teradata, per cercare i messaggi che indicano che una sessione è stata interrotta. Questo è un problema comune per le connessioni JDBC in un pool di connessioni, poiché le connessioni di questo tipo possono restare inattive per una parte significativa della relativa durata. L'amministratore del database Teradata non deve disconnettere forzatamente le sessioni Teradata inattive che sono connessioni JDBC in pool, poiché ciò vanifica lo scopo del pool di connessioni JDBC.
  2. Problema di rete e/o errore di rete temporaneo. Ciò può includere situazioni come il passaggio di un laptop da una connessione di rete cablata a una wireless (o viceversa) o la connessione o la disconnessione da una VPN.
  3. Hardware di rete difettoso, come switch, router o servizi di bilanciamento del carico.
  4. Si è verificato il riavvio del database Teradata. Questo può essere verificato esaminando /var/log/messages sul nodo del database Teradata, per cercare i messaggi che indicano che si è verificato un riavvio del database Teradata.
Numero articolo Knowledge

001473913

 
Caricamento
Salesforce Help | Article