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Erreur "system library:fopen:Unknown error" lors de l'utilisation d'OpenSSL pour générer le fichier CSR

Date de publication: Aug 24, 2022
Description
Lorsque vous utilisez Open SSL pour générer un fichier de demande de signature de certificat (CSR), une erreur du type suivant peut se produire :
 
<number>:error:0200107B:system library:fopen:Unknown error:.\crypto\bio\bss_file.c:169:fopen('"C:\Program Files\Tableau\Tableau Server\<version>\apache\conf\openssl.cnf"','rb')
<number>:error:2006D002:BIO routines:BIO_new_file:system lib:\.crypto\bio\bss_file.c:174:
<number>:error:0E078002:configuration file routines:DEF_LOAD:system lib:.\crypto\conf\conf_def.c:199:

Cause

OpenSSL ne parvient pas à trouver le fichier openssl.cnf.

 

Résolution
  1. Vérifiez que le fichier openssl.cnf existe bien dans le dossier de destination et n'est pas renommé. 
  2. Si le fichier existe, exécutez la commande suivante avant de générer le fichier CSR. Assurez-vous que vous n'utilisez pas des guillemets dans la commande.
set OPENSSL_CONF=c:\Program Files\Tableau\Tableau Server\<version>\apache\conf\openssl.cnf
Ou :
set OPENSSL_CONF=c:\Program Files (x86)\Tableau\Tableau Server\<version>\apache\conf\openssl.cnf
Numéro d’article de la base de connaissances

001473937

 
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Salesforce Help | Article