Loading

La vista aparece en blanco después de publicar una vista con un filtro en el que se utiliza la función "username"

Fecha de publicación: Nov 30, 2023
Descripción
Al publicar un libro de trabajo en Tableau Server, un filtro rápido en el que se utilizan las funciones username() o fullname() conservará el valor que estaba en uso en el momento de la publicación. Si el usuario que inició sesión en Tableau Server no es el mismo usuario del filtro, la vista aparecerá en blanco.

Cause

Los filtros estarán establecidos en el valor que tenían en el momento de la publicación y no se actualizan automáticamente a una opción válida en función del usuario que acceda a la vista. 
 
Solución

Opción 1:

  1. Cambie el valor del filtro a (Todos).
  2. Vuelva a publicar la vista.

Opción 2:

Haga que el usuario de Tableau Server siga estos pasos:
  1. Vaya al libro de trabajo publicado.
  2. Seleccione su nombre en el filtro.
  3. Haga clic en el enlace Recordar mis cambios.
Recursos adicionales
Para mostrar que quiere que se incluya esta funcionalidad en una futura versión del producto, vote desde la siguiente idea de la Comunidad: Establecer valores de filtro predeterminados según el usuario de Tableau Server.


Comente sobre este artículo… Foro de comentarios
Número del artículo de conocimiento

001473949

 
Cargando
Salesforce Help | Article