Loading

Errore "Setup Wizard ended prematurely" durante l'upgrade

Data pubblicazione: Oct 13, 2022
Descrizione
Quando tenti di aggiornare Tableau Desktop, potrebbe verificarsi il seguente errore:

Tableau <version> Setup Wizard ended prematurely ((La procedura guidata di configurazione di Tableau <versione> è terminata in modo anomalo)

Tableau <version> setup ended prematurely because of an error. Your system has not been modified. To install this program at a later time, please run the installation again. (La configurazione di Tableau <versione> è terminata in modo anomalo a causa di un errore. Il sistema non è stato modificato. Per installare questo programma in un secondo momento, eseguire nuovamente l'installazione.)

Click the finish button to exit Setup. (Fai clic sul pulsante Fine per uscire dalla configurazione.)

Cause

Una versione precedente di Tableau Desktop non è stata rimossa correttamente.
Risoluzione
I seguenti passaggi di risoluzione dei problemi potrebbero risolvere il problema.

Passaggio 1: Esegui un'installazione pulita di Tableau Desktop

  1. Nel pannello di controllo, fai clic su Programmi e funzionalità, quindi disinstalla Tableau Desktop.
  2. Esegui il backup e quindi elimina C:\Utenti\<nome utente>\Documenti\My Tableau Repository.
  3. Elimina la seguente cartella: C:\Programmi\Tableau.
  4. Riavvia il computer con Tableau Desktop.
  5. Scarica un nuovo programma di installazione di Tableau Desktop.
  6. Fai clic con il pulsante destro del mouse sul file di installazione di Tableau Desktop, quindi seleziona Esegui come amministratore.

Passaggio 2: Reinstalla la versione precedente di Tableau Desktop 

Se si verifica ancora un errore dopo aver seguito la procedura descritta nel Passaggio 1, utilizza la seguente procedura:
  1. Esegui i passaggi 1-3 della procedura precedente.
  2. Scarica il programma di installazione della versione di Tableau Desktop precedentemente installata.
  3. Fai clic con il pulsante destro del mouse sul file di installazione di Tableau Desktop per la versione precedente, quindi seleziona Esegui come amministratore.
  4. Se l'installazione è stata eseguita correttamente, scarica la nuova versione di Tableau Desktop e passare a quella versione. Per maggiori informazioni, vedi Aggiornamento di Tableau Desktop nella Knowledge Base di Tableau.

Passaggio 3: Esegui Fix It

Numero articolo Knowledge

001473951

 
Caricamento
Salesforce Help | Article