Loading

Fehler "SQL Server does not exist or access denied" (SQL Server existiert nicht oder Zugriff verweigert) beim Öffnen der Arbeitsmappe oder Zugriff auf das Dashboard

Veröffentlichungsdatum: Aug 24, 2022
Beschreibung
Wenn Sie versuchen, eine Arbeitsmappe in Tableau Desktop zu öffnen oder ein Dashboard auf Tableau Server anzuzeigen, kann der folgende Fehler auftreten:
 
TableauException: [Microsoft][ODBC SQL Server Driver][DBNETLIB] SQL Server does not exist or access denied. ([Microsoft][ODBC SQL Server-Treiber][DBNETLIB] SQL Server existiert nicht oder Zugriff verweigert.)
[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Connect()).
Unable to connect to the server <server name>. (Verbindung mit Server <server name> kann nicht hergestellt werden.) Check that the server is running and that you have access privileges to the requested database. (Prüfen Sie, ob der Server ausgeführt wird und ob Sie Zugriffsberechtigungen für die angeforderte Datenbank besitzen.)

Cause

Tableau Desktop oder Tableau Server kann nicht mit der SQL-Serverdatenbank kommunizieren.

Zudem verfügen die Computer, auf denen Tableau Server ausgeführt wird, nicht über die neue Version des Microsoft SQL Server-Treibers und verwenden den SQL Server-Standardtreiber, der mit dem Windows-Betriebssystem installiert wurde. Der SQL Server-Standardtreiber kann für viele Microsoft SQL Server-Funktionen verwendet werden, erweiterte Funktionen aus neueren Versionen von Microsoft SQL Server sind jedoch nicht kompatibel mit dem SQL Server-Standardtreiber.
Lösung
Mithilfe der folgenden Schritte kann das Problem gelöst werden:
  • Laden Sie auf dem Computer, auf dem Tableau Server ausgeführt wird, von der Tableau-Seite Treiber und Aktivierung den Treiber für Microsoft SQL Server herunter und installieren Sie ihn. Wenn Tableau Server in einer verteilten Umgebung ausgeführt wird, müssen die Treiber auf allen Computern, auf denen Tableau Server ausgeführt wird installiert werden – auch auf allen Arbeitscomputern. Starten Sie Tableau Server nach dem Herunterladen und Installieren des Treibers neu. Weitere Informationen finden Sie unter tabadmin restart in der Tableau-Hilfe.
  • Vergewissern Sie sich, dass die in der Fehlermeldung angegebene SQL Server-Datenbank ausgeführt wird.
  • Stellen Sie sicher, dass Tableau Desktop oder Tableau Server nicht an der Kommunikation mit SQL Server gehindert wird, etwa durch eine Firewall.
  • Überprüfen Sie die SQL Server-Protokolldateien, um sicherzustellen, dass der Benutzer oder Tableau Server-"Run As User" (Als Benutzer ausführen) die Berechtigung zum Zugriff auf die Datenbank hat. Weitere Informationen finden Sie unter "Run As User" (Als Benutzer ausführen) in der Hilfe von Tableau.
Nummer des Knowledge-Artikels

001473974

 
Laden
Salesforce Help | Article