Loading

打开工作簿或访问仪表板时出现错误“SQL Server 不存在或访问被拒绝”

发布日期: Aug 24, 2022
描述
当您尝试在 Tableau Desktop 中打开工作簿或在 Tableau Server 上查看仪表板时,可能会发生以下错误:
 
TableauException: [Microsoft][ODBC SQL Server Driver][DBNETLIB] SQL Server 不存在或访问被拒绝。
[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Connect()).
Unable to connect to the server <server name>.请检查服务器是否正在运行,并且您具有所请求的数据库的访问权限。

Cause

Tableau Desktop 或 Tableau Server 无法与 SQL Server 数据库通信。

此外,运行 Tableau Server 的计算机没有新版本的 Microsoft SQL Server 驱动程序,它使用的是与 Windows 操作系统一起安装的默认 SQL Server 驱动程序。默认的 SQL Server 驱动程序使用许多 Microsoft SQL Server 功能,但较新版本的 Microsoft SQL Server 的高级功能与默认的 SQL Server 驱动程序不兼容。
解决方案
以下故障排除步骤或许能解决该问题。
  • 在运行 Tableau Server 的计算机上,从 Tableau 驱动程序和激活页面中下载并安装 Microsoft SQL Server 驱动程序。如果正在分布式环境中运行 Tableau Server,则在运行 Tableau Server 的所有计算机上安装驱动程序,包括工作软件。 下载并安装驱动程序后,重启 Tableau Server。有关详细信息,请参见 Tableau 帮助中的 tabadmin 重启
  • 确认错误消息中提到的 SQL Server 数据库正在运行。
  • 确保没有任何东西阻止 Tableau Desktop 或 Tableau Server 与 SQL Server 通信,例如防火墙。
  • 检查 SQL Server 日志文件,验证用户或 Tableau Server 运行身份用户有权访问数据库。有关详细信息,请参见 Tableau 帮助中的用户运行身份
知识文章编号

001473974

 
正在加载
Salesforce Help | Article