Loading

Error "Unable to connect to the server" al conectarse a fuentes de datos en Mac

Fecha de publicación: Jul 20, 2023
Descripción
Si se conecta a una fuente de datos usando únicamente un nombre de host y usa Tableau Desktop en Mac, podría producirse uno de estos errores:
 
An error occurred while communicating with the <data source type> data source <servername or IP address>. (Se ha producido un error al comunicarse con <nombre de servidor o dirección IP> de la fuente de datos <tipo de fuente de datos>). Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database. (No se puede conectar con el servidor "<dirección del servidor>". Compruebe que el servidor esté en ejecución y que disponga de privilegios de acceso a la base de datos solicitada).
O:
Unable to connect to the ODBC Data Source. Check that the necessary drivers are installed and that the connection properties are valid. (No es posible conectarse a la fuente de datos ODBC. Compruebe si se han instalado los controladores necesarios y si las propiedades de conexión son válidas).
[Simba][SqlServerODBC] (100) Failed to connect to the SQL Server instance: Server not found. (Error al conectarse a la instancia de SQL Server: servidor no encontrado).
O:
Unable to connect to the server "DataServer". Check that the server is running and that you have access privileges to the requested database. (No se puede conectar con el servidor "servidor de datos". Compruebe que el servidor esté en ejecución y que disponga de privilegios de acceso a la base de datos solicitada).
O:
Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database. (No se puede conectar con el servidor. Compruebe que el servidor esté en ejecución y que disponga de privilegios de acceso a la base de datos solicitada).
 

Cause

El equipo que ejecuta Tableau Desktop no puede resolver el nombre de servidor a una dirección IP o el puerto utilizado por la fuente de datos para la comunicación está bloqueado.
Solución
  • Conéctese a la fuente de datos mediante el nombre de dominio completamente calificado. Por ejemplo: ServerName/Domain o servername.domain.com
  • Hable con su equipo local de TI para asegurarse de que los puertos que la fuente de datos utiliza para la comunicación estén abiertos. 
Recursos adicionales
En algunos entornos, Active Directory (AD) y WINS están configurados para ayudar a los equipos de Windows a consultar la dirección IP de los servidores. Los equipos Mac que no estén configurados para usar WINS y AD para la resolución de nombres podrían requerir nombres de dominio completamente calificados para poder consultar correctamente la dirección IP del servidor.

Para determinar si un Mac es capaz de resolver un nombre de servidor a una dirección IP, use la utilidad de ping desde la línea de comandos o la aplicación GUI de la utilidad de red.

Opción 1: línea de comandos

  1. Vaya a /Applications/Utilities.
  2. Abra el Terminal y escriba ping <servername>.

Opción 2: aplicación GUI

  1. Vaya a /Applications/Utilities.
  2. Abra la Utilidad de red y seleccione la pestaña Ping.
  3. En Enter the network address to ping (Escribir la dirección de red a la que hacer ping), escriba el nombre del servidor y haga clic en Ping.


Número del artículo de conocimiento

001473987

 
Cargando
Salesforce Help | Article