Loading

Erreur "Unable to connect to the server" lors de la connexion à des sources de données sur Mac

Date de publication: Jul 20, 2023
Description
Lorsque vous vous connectez à une source de données en utilisant uniquement un nom d'hôte, avec Tableau Desktop sur un Mac, l'une des erreurs suivantes peut se produire :
 
An error occurred while communicating with the <data source type> data source <servername or IP address>. Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database. (Une erreur s'est produite lors de la communication avec la source de données '<nom de la source de données>'. Impossible de se connecter au serveur. Vérifiez que le serveur est en cours d'exécution et que vous disposez de privilèges d'accès à la base de données demandée.)
Ou :
Unable to connect to the ODBC Data Source. Check that the necessary drivers are installed and that the connection properties are valid. (Impossible de se connecter à la source de données ODBC. Vérifiez que les pilotes nécessaires sont installés et que les propriétés de connexion sont valides.)
[Simba][SqlServerODBC] (100) Failed to connect to the SQL Server instance: Server not found. (Impossible de se connecter à l'instance SQL Server. Serveur associé introuvable.)
Ou :
Unable to connect to the server "DataServer". Check that the server is running and that you have access privileges to the requested database. (Impossible de se connecter au serveur "DataServer". Vérifiez que le serveur est en cours d'exécution et que vous disposez de privilèges d'accès à la base de données demandée.)
Ou :
Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database. (Impossible de se connecter au serveur. Vérifiez que le serveur est en cours d'exécution et que vous disposez de privilèges d'accès à la base de données demandée.)
 

Cause

L'ordinateur exécutant Tableau Desktop ne peut pas résoudre le nom du serveur en une adresse IP, ou le port utilisé par la source de données pour communiquer est bloqué.
Résolution
  • Connectez-vous à la source de données en utilisant le nom de domaine qualifié complet. Par exemple : ServerName/Domain ou servername.domain.com
  • Adressez-vous à votre équipe informatique locale pour vérifier que les ports utilisés par votre source de données pour communiquer sont ouverts.
Ressources supplémentaires
Dans certains environnements, Active Directory (AD) et WINS sont configurés pour aider les ordinateurs Windows à rechercher l'adresse IP des serveurs. Les Mac qui ne sont pas configurés pour utiliser WINS et AD pour la résolution de nom peuvent avoir besoin de noms de domaine qualifiés complets pour rechercher avec succès l'adresse IP du serveur.

Pour déterminer si un Mac est capable de résoudre un nom de serveur en une adresse IP, utilisez l'utilitaire Ping depuis la ligne de commande ou l'application GUI de l'utilitaire réseau.

Option 1 : Ligne de commande

  1. Accédez à /Applications/Utilitaires.
  2. Ouvrez Terminal, puis tapez ping <servername>.

Option 2 : Application GUI

  1. Accédez à /Applications/Utilitaires.
  2. Ouvrez Utilitaire réseau, puis sélectionnez l'onglet Ping.
  3. Dans Entrez l'adresse réseau pour le test Ping, entrez le nom du serveur, puis cliquez sur Ping.


Numéro d’article de la base de connaissances

001473987

 
Chargement
Salesforce Help | Article