Loading

Error "Unable to connect to the server" When Connecting to Data Sources on Mac

Data pubblicazione: Jul 20, 2023
Descrizione
Quando ti connetti a un'origine dati utilizzando solo un nome host, utilizzando Tableau Desktop su Mac, potrebbe verificarsi uno dei seguenti errori:
 
An error occurred while communicating with the <data source type> data source <servername or IP address>. (Si è verificato un errore durante la comunicazione con l'origine dati <tipo di origine dati> <nomeserver o indirizzo IP>)Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database. (Impossibile connettersi al server "<indirizzo server>". Verifica che il server sia in funzione e di disporre dei privilegi di accesso al database richiesto.)
O:
Unable to connect to the ODBC Data Source. Check that the necessary drivers are installed and that the connection properties are valid. (Impossibile connettersi all'origine dati . Verifica che i driver necessari siano installati e che le proprietà della connessione siano valide).
[Simba][SqlServerODBC] (100) Failed to connect to the SQL Server instance: Server not found.
O:
Unable to connect to the server "DataServer". Check that the server is running and that you have access privileges to the requested database. (Impossibile connettersi al server "<indirizzo server>". Verifica che il server sia in funzione e di disporre dei privilegi di accesso al database richiesto.)
O:
Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database. (Impossibile connettersi al server "<indirizzo server>". Verifica che il server sia in funzione e di disporre dei privilegi di accesso al database richiesto.)
 

Cause

Il computer che esegue Tableau Desktop non è in grado di risolvere il nome del server per un indirizzo IP, oppure la porta utilizzata dall'origine dati per comunicare è bloccata.
Risoluzione
  • Connettiti all'origine dati utilizzando il nome di dominio completo. Ad esempio: ServerName/Domain o servername.domain.com
  • Collabora con l'IT locale per garantire che le porte utilizzate dalla tua origine dati per comunicare siano aperte. 
Risorse aggiuntive
In alcuni ambienti, Active Directory (AD) e WINS sono configurati per supportare i computer Windows nell'individuazione dell'indirizzo IP dei server. I Mac che non sono configurati per utilizzare WINS e AD per la risoluzione dei nomi potrebbero richiedere nomi di dominio pienamente qualificati per cercare correttamente l'indirizzo IP del server.

Per stabilire se un Mac è in grado di risolvere il nome di un server con un indirizzo IP, utilizza l'utilità ping dalla riga di comando o l'applicazione Network Utility GUI.

Opzione 1: riga di comando

  1. Vai a /Applicazioni/Utility.
  2. Apri Terminale, e quindi digita ping <servername>.

Opzione 2: applicazione GUI

  1. Vai a /Applicazioni/Utility.
  2. Apri Utilità di rete, e quindi seleziona la schedaPing.
  3. In Immetti l'indirizzo di rete nel ping, digita il nome server e fai clic su Ping.


Numero articolo Knowledge

001473987

 
Caricamento
Salesforce Help | Article